Problems with writing log entries to custom sensor since 2022.6

Hey all, I have for some projects of mine a few sensors to write log entries to, this way I have all project related logs in 1 logfile. Now since 2022.6.2 it’s not working. The whole sensor doesn’t even appear in the logbook page. This is an example sensor:

  sensor:
  # Logbook sensor
  - platform: template
    sensors:
      logbook_test:
        unique_id: "logbook_test"
        friendly_name: "Logbook Test"
        value_template: >-
          {% set Tests = [
              "switch.athom_smart_plug",
              "sensor.chore_1_prev"
            ]%}
            {{
              expand(Tests)
              |list()|count()
            }}
        unit_of_measurement: "Entities"

The entries come from either automations or Node-RED flows. An example from Node-RED is build like so:

Domain logbook
Service log
Data
{
    "message": "Test bericht vanuit Node-RED",
    "name": "Test",
    "entity_id": "sensor.logbook_test",
    "domain": "sensor"
}

Without the domain part I saw them appear in the general log page but I noticed the domain is needed (tested on an existing entity). And in my Recorder and Logbook settings I have the following include:

    entity_globs:
      # Alle logboek sensors
      - sensor.logbook_*

This all worked fine, but for some reason I do have History now for these entities, but no logbook and I can’t even find them in the logbook dashboard. I couldn’t see anything in the breaking changes that would explain this, but I might be looking wrong at it.

Ok, so it looks like template sensors don’t have logbooks anymore. So I decided to test with a different type, input_text is my current test. And at first I was enthousiastic because it works. The example script on the site for instance works fine:

     
  script:
    add_logbook_entry:
      alias: "Add Logbook"
      sequence:
        - service: logbook.log
          data:
            name: Test Script
            message: Entry vanuit script
            # Optional
            entity_id: input_text.logbook_test
            domain: input_text

I saw the entry appear under the filtered input_text.logbook_test. Then switched back and forth and the entry was disappeared from the filtered logbook. It still shows in the general logbook, but when I filter it the entry is gone. If I put the text into the textbox itself it does keep the logging history linked to the entity.

Ow I’m running an external MariaDB which I rebuild because if errors after upgrading, not sure if that has anything to do with it.

The sensor domain was always excluded from the logbook.

So it was a bug on my system that it worked all that time on my sensors?

But then it’s still weird that the log entries disappear when I use a filter on the input_text right? When I use the logbook.log action.

action:
    - service: logbook.log
      data:
        entity_id: input_text.logbook_vaatwasser
        domain: input_text
        name: "Gestopt"
        message: "De automatisering voor de vaatwasser is gestopt. Aantal watt is onder
          de 1 en de boolean is uitgezet."

It shows in the general log, but not when I filter on input_text.logbook_vaatwasser. Only if I have the filter open already it appears, but then disappears when reloaded.