Quick question: could !secret in !include be causing problems?

Hi all, quick question: it seems that since I moved my sensors information to a separate file, I am seeing all sorts of errors in the log, and my hass.io entry is no longer showing in the left panel. Is this a coincidence or a bug?

configuration.yaml:

sensor: !include sensors.yaml

sensors.yaml

  • platform: waqi
    token: !secret waqi_token
    locations: whereilive
    scan_interval: 1800

moved sensors back to configuration.yaml, but still hass.io not showing…

is there some sort of checklist to determine why this could be happening (i.e. hass.io no longer available in the left panel)?

Am slowly deconstructing my setup, disabling sensors, automations, … but still no hassio.io. Next step would be to do a complete reinstall, but I would like to avoid this.
I don’t have ssh access to my Pie, so I won’t be able to update / upgrade without hass.io

Includes and secrets are just ways of saying ‘replace this with the contents of that’, when homeassistant runs it basically uses one long configuration.yaml which is merged out of that method, so if your configuration.yaml looks like

homeassistant:
  password: !secret password 

sensor: !include sensor.yaml

Then when homeassistant is starting it will merge the secret and the include to create

homeassistant:
  password: HorseCakeBobbleOrange

sensor:
  platform: darksky 
  [...etc...]

This is then your single configuration that homeassistant uses.

So, moving the stuff around won’t make any difference, you need to find the cause of the errors.

Re hassio menu, you need config: or hassio: in there somewhere. Other than that we’re going to need to see those errors.

Hi, thanks for responding and thanks for the explanation of the includes. I figured as much that this was just a coincidence, but it did help me clean up some config.

I do have this in my configuration.yaml:

# Enables the frontend
frontend:

# Enables configuration UI
config:

Log (after I’ve just hard-restarted my raspberry pie earlier today):

2018-05-25 17:14:17 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=95 from 2018-05-25 09:49:45.862149)
2018-05-25 17:14:45 ERROR (MainThread) [homeassistant.components.device_tracker] Error setting up platform google_maps
Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/init.py”, line 184, in async_setup_platform
disc_info)
File “/usr/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/google_maps.py”, line 36, in setup_scanner
scanner = GoogleMapsScanner(hass, config, see)
File “/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/google_maps.py”, line 55, in init
self._update_info()
File “/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/google_maps.py”, line 68, in update_info
dev_id = 'google_maps
{0}'.format(slugify(person.id))
File “/usr/lib/python3.6/site-packages/homeassistant/util/init.py”, line 43, in slugify
text = normalize(‘NFKD’, text)
TypeError: normalize() argument 2 must be str, not None
2018-05-25 17:16:08 ERROR (MainThread) [homeassistant.core] Error doing job: Task was destroyed but it is pending!
2018-05-25 17:17:45 ERROR (SyncWorker_0) [homeassistant.core] Error doing job: Task was destroyed but it is pending!
2018-05-25 17:22:20 ERROR (MainThread) [homeassistant.core] Error doing job: Task was destroyed but it is pending!
2018-05-25 17:28:01 ERROR (MainThread) [homeassistant.core] Error doing job: Task was destroyed but it is pending!
2018-05-25 17:40:23 ERROR (MainThread) [homeassistant.core] Error doing job: Task was destroyed but it is pending!

Not a lot I guess…

The warning at the start is just because the database didn’t close down properly when you restarted.

The next one is a problem with a device tracker, probably be solved when you update if we can ever get you to the hassio menu.

The others are unlikely to be anything of interest and are currently subject to an investigation by the devs as nobody seems to know where they’re coming from.

So, yeah, not a lot going on in the logs. Have you tried clearing the browser cache in case it is there, but the browser is showing a cached version from when it wasn’t?

Have you tried adding hassio: to the configuration just in case that kicks it in to action?

Umm, can’t think of anything else atm :slight_smile:

Thank you for looking into this with me.

changed config: to hassio: , cleared cache and then rebooted, no result.

added config: back in, so that now it has both, cleared cache again and then rebooted: BAM! We have hass.io back in the frontend!

Don’t know how, don’t know why, but hey, if it works…

1 Like

Glad you got sorted :+1: