Rachio zones not updating

Tags: #<Tag:0x00007fc419b56e88>

I have a Rachio 3 integrated into my HA setup. All of the info from the controller seems to populate and update correctly in HA (zones, custom names, etc). However, the zone switches in HA do not toggle on when the zones are watering (either manually or through a schedule). I’ve read earlier posts about a fix using hass_url_override: but the configuration checker keeps rejecting this as an invalid option for the Rachio integration. Anyone else have this issue or have any ideas as to what might be going?

hass_url_override is depreciated.

Is your setup accessible from the outside world either with HA cloud or another method?

It is accessible via Duck DNS. My HA seems to be connecting to the Rachio cloud service since it’s pulling in Rachio system information configured via the Rachio app.

The initial setup and pulling of devices should work whether or not your instance is accessible from the outside. The updates use webhooks, which are what needs to know where to find your device from the outside.

Do you have a base_url set?

If not, try adding this to your configuration.yaml and restart.

http:
  base_url: YOUR_EXTERNAL_ADDRESS

This will tell the webhooks where to point to reach your HA instance.

Thanks! I did have a base_url set but I had it as:

http:
  base_url: YOUR_EXTERNAL_ADDRESS:8123

I removed the port designation and now the Rachio entities in HA are updating correctly. I’m not sure why I had the port in there to begin with. I’ll have to play around to see if there is something I broke now by removing it.

Honestly I would have thought the port would need to be there but if it’s working, great!

So FYI to anyone else. I have Cloudflare as my domain/dns host and had their proxy turned on. I had to disable that for this to work.

I’m running into what may be the same issue noted above.

I can trigger watering zones using the Rachio ‘switches’ in HA just fine, but the switches do not stay toggled or reflect the state of any currently running watering schedule. That last part is important to me, since I’m looking to create some Node-RED automations that will incorporate those states.

Researching this, I suspect I have some form of remote access that’s blocking Rachio’s use of webhooks to properly update the current status. For the record, I’m using a combo of Duck DNS and the NGINX Home Assistant SSL proxy add-on to provide remote SSL access to HA.

I found suggestions online to add either a base_url or hass_url_override entry with my personal duckdns address to my HA config, but neither worked and both are now deprecated. I tried this both with and without corresponding port numbers (I have a firewall rule set up to forward external port xxxxx to port 8123 local.) and am running HA core-2021.3.4 supervised.

At this point I realize that I’m over my head on debugging this from both a networking and current HA build perspective. Can anyone offer some troubleshooting tips?

Do you have an external_url set up?

base_url was depreciated, internal and external url config is the replacement.

1 Like

Ah, the Configuration/General Menu in the UI. The last time I looked at that was probably when I first set up HA eons ago.

And you are 100% right - I added an entry to the External URL field and now it works. Thanks very much!

Hopefully the next person that has this or a similar issue gets this thread as a search hit rather than that other outdated information.

1 Like