Raspberry Pi 3B & Jeyi I9 Gtr NVMe (/w Kingston SA2000M8 SSD)


Hardware used:
system: Raspberry Pi 3B
SSD USB 3.1 enclosure: Jeyi I9 Gtr NVMe
NVMe SSD: Kingston SA2000M8 SSD

Raspberry Pi 3B running Home Assistant is running fine and stable from a USB stick. I wanted to go for a more permanent solution since SD and USB sticks fail eventually. So I bought a NVMe SSD and a nice small enclosure to stick next to the Pi.

This solution runs fine and seems stable as long as there is a bare version of Home Assistant running. (Home Assistant OS, as there’s nothing else I want to do with the Pi.) As soon as I recover my backup it runs fine initially. Within the hour it will crash and lockup. The only way to recover is to cut power and reboot it. Then it will eventually crash again.

Solutions tried:
I thought it might be a power related issue. The fully configured and working image of my Home Assistant demands more from the Pi and SSD then a bare clean installation. Therefore I bought a USB y-cable. Like this:

First I stuck both USB male connectors in the Pi to power the SSD. That gave the same result. It still crashed within an hour.

Secondly I tried to give it extra power through a spare Apple USB adapter I had. That also didn’t work.

I do not know what to try next. I really want it to run from this SSD.