Re-discover deleted devices

Bought a new router, and this one assigned different IPs to all my devices on the network. As a result, most of them now show up as “Failed setup, will retry” in HA, hence, I decided to remove them all, in the hopes that HA will re-discover them upon reboot (or whatever). That, however, has not happened yet, nor does it look like it ever will.

What can be done to get them re-discovered please?

It should.

Try adding them manually.

Thanks for the advice, but it is not working. Attempting to add the entities/devices manually throws a “not detected” error, or something in that vein. Also, I cannot access HA via the usual http://homeassistant.local:8123/ link, but I have to actually input the local IP of the HA box.

Any other ideas?

  • Go to: HA → Settings → System → Network → Configure network interfaces → IPv4

→ Make sure it is set to “Automatic”.

  • Go to: HA → Settings → System → Network → Configure network interfaces → IPv6

→ Make sure it is set to “Disabled”

  • Go to: HA → Settings → System → Network → Home Assistant URL → Local network

→ Make sure it is set to “Automatic”.

Now reboot the Host (System Reboot).

If rediscovering is still not working as expected go to:

HA → Settings → System → Network → Configure network interfaces

Click on the 3 vertical dots to the lower left of that box → IP Information

Check the Gateway-IP and make sure it shows the IP-address of your new router.

Thanks, but I do not have this setting ^^
Under “Network,” I only have “Host name” and “Configure network interfaces.”

Right below " Netzwerkschnittstellen konfigurieren" ?

Assuming your HA server is connected through ethernet cable (not WiFi) make sure IPv4 and IPv6 below “WLP 150” is set to “Disabled”.

  • Click on the 3 vertical dots to the lower left of that box → IP Information
  • Check the Gateway-IP and make sure it shows the IP-address of your new router.

Hmm, I think I know what’s happening: my new router assigns by default each of its LAN ports a different network (see below) which is why HA (which is on the 192.168.100.xxx network) does not see any of the devices on the other networks. Save for consolidating all these disparate networks into one big network, is there anything else that can be done?

Or is it that I don’t really need all these networks separate to begin with?

1 Like

What make and model is that router? You should be able to reconfigure the router settings to use only one subnet for all ports.

Thanks, I don’t think lumping them all up into one big network would be a problem. The question is, would I not be forfeiting any advantages that keeping them separate brings? Why did they set it up it this way in the first place?

Router is a QNAP QHora-322.

I don’t see any advanages keeping every LAN port on a different subnet but just an additional effort for the maintenance of your LAN.

I have never heard of a QNAP QHora-322 router (will dig into it later). As for separation of your IoT devices I personally use VLANs.

I have no idea and this is the first time I hear about this kind of default setting.

Alright, so I removed the subnetting, and now things have almost gone back to normal. And I say “almost” because HA still does not detect my HomeKit devices. What up with that? Do I have to do anything special to have them show up? I, frankly, do not recall what I did the first time around to make them appear. (Note also that I do not have a HomeKit hub.)