Realtime camera streaming without any delay - WebRTC

Hey all. I rewrited addon to custom component. It means now it works not only with, but also with Docker, venv and Windows. And now it has Lovelace card.

You need stop addon, because they can’t work together. And you need clean your browser cache to find new lovelace card in cards list


Wow, big news! Thanks Alexey!

You’re the best! No idea how this works on my Huawei tablet now but it does! Normal WebRTC isn’t able to run on it so IDK what type of wizardry you did, but I’m not complaining.

Thank you so much :+1: . It’s working with my old Android 5 Tablet and Fully Remote Browser.

1 Like

did you mean Fully Kiosk Browser? I tried it on my Amazon Fire tablet but it crashed.

Yes, big news!
Had a lot of trouble to view my UniFi G3 Flex (standalone) camera in Lovelace without high latency and not to drop off from the UI (drop off was the biggest problem). Tried @scstraus solutions I tried all the camera platforms so you don't have to (not Live555Proxy or ONVIF)

But this WebRTC component seems to be very stable!

Yes I mean the Fully Kiosk Browser.

1 Like


any suggestions on what i’m missing here
2021/04/12 13:07:11 Client Not Send ACK (probably the browser is minimized) or tab not active Close client
2021/04/12 13:07:11 WritePacket WebRTC Client Offline

Yes it works now ! great.
But i can’t see the video with the Home Assistant App (android)

Alexey’s custom component is definitely the solution I think a lot of us were hoping for.

Anecdotal, but although the lovelace card is super reliable with 1-2 cards/cameras… the streams become less likely to load the more I duplicate things out (3, 4, etc. cards). I experienced similar issues using Mal’s card.

Wow! What a nice add-on! Finally my Ender3 Cam is on my dashboard with no delay at all.

Problem because only 10 simultaneous connections allowed (50000-50009 ports). Will be fixed when I add this setting to GUI.


@AlexxIT Great work!
One Quick question: How can the “player” bar be removed?

Thank you

Hi AlexxIT, after upgrade to version 1.0.3. my Android 5 Tablet stops working. I can only see a black card with turning play symbol. Reverting to version 1.0.2 does’t solve the issue. I think you change the container which is loaded from your repository. In my case it`s the version for Raspberry PI 3B+.

Custom component don’t using containers. Check version 1.0.1

Version 1.0.1 works for me, thanks. May I ask you what is the difference with the newer version?

I don’t know. Have same issue with user with Honor mobile phone.

Hi, @AlexxIT like usual one of the best addon yet again. However, I just realize is that not all camera is working. 2 YiCam hack version doesn’t seem to be broadcasting even though it works on your previous add-on version. Furthermore, 1.0.4 seems to be working from time to time on my MacBook. In most cases, I got blank pages. This happens in both Firefox and Chrome. On mobile device 4 camera is working perfectly on both iPhone X and Android OnePlus 7T Pro, except for the two cam mentions

I can confirm that YI dome 1080p and Yi home 1080p with yi-hackMstar and yi-hack5 are working just fine. Only yi-outdoor camera with yi-hack4 is not working with error like this:

Can't start stream: rtsp://rtsp:192.168.1.XXX:554/av_stream/ch0, because: 0, message='Attempt to decode JSON with unexpected mimetype: ', url=URL('http://localhost:8083/stream')

so far not working… so I install back the add-on rather the web version…