Reboot and insert proper boot device ( for NUC)


Using etcher to flash latest image before booting my NUC. Latest bios is installed on my NUC. When I power on my NUC and boot from usb I am getting the message ‘reboot and insert a proper boot device’. booting another image works just fine.

Does anyone know what could be the problem?

There’s a protected O/S mode setting you probably need to disable

If they are the same just check whether their checksum are too.
Wondering whether the distributed images are signed and provided with a checksum.

I cannot seem to find the protected O/S option within the NUC’s BIO and how will the checksum will help to boot the unit?

secure boot is off and I am not running uefi boot. Tried another disk but without luck.

Just yesterday I spent half day to understand why I couldn’t flash the image as the first time.
Perhaps I changed something that I had to download the image again.
But when I checked the two image the md5sum were the same. The only thing I’ve done it was to repack the image with 7zip, which saved 25% of the space.
I don’t understand whether that would affect something.