Recorder broken after update to 0.93.2

This morning I updated to version 0.93.2. After the update the recorder stopped working.

This is the error I’m seeing:

Error executing query: (MySQLdb._exceptions.OperationalError) (1206, ‘The total number of locks exceeds the lock table size’)
[SQL: UPDATE recorder_runs SET end=%s, closed_incorrect=%s WHERE recorder_runs.run_id = %s]
[parameters: (datetime.datetime(2019, 6, 4, 10, 42, 22, 544458, tzinfo=), 1, 155)]
(Background on this error at: Error Messages — SQLAlchemy 2.0 Documentation)

Does anyone have any Idea how to solve this? I’m running a mariaDB on my synology nas.

How important is the previous data to you?

If the answer is “not at all” just copy your mariaDB addon config, and reinstall it (pasting back the config).

MariaDB is running on a Synology NAS. Not on the Pi running hassio.

So reinstall the mariaDB container?

I tried reinstalling MariaDB without luck

I solved this by changing the innodb_buffer_pool_size to 128M

Hi, How did you do this please?