Remote Access Won't Work

I’m pretty new to Home Assistant and I love it so far. Except for one thing. It can only be used locally. I know that there is the cloud subscription, but I’m not interested in paying for that. I tried to set up remote access with DuckDNS, but I’m having a really hard time with that. I followed this video exactly, but after I save the config.yaml file and restart, HA never comes back up. Not on the ip address or on the domain.

Before you all ask, yes. I forwarded the ports. And I’m 99% sure I did it right.

I also tried to follow this video as well, but the results were not any better.

And every time I restart HA after thinking that I finally got it, it basically bricks itself and I can’t even open HA. I have to delete the virtualmachine, add it again, and start from scratch.

I heard that there was an update that required a different setup, so I also tried following Peyanskis article on remote access and sure enough, I got the same exact results. Any ideas? Are there any questions I can answer to help with this?