Remote keyboard no events showing

I am trying to set up remote keyboard.

I am using HAOS in proxmox VM. I have passed the usb through in proxmox and the keyboard is showing up in hardware as an event.

I have this in my yaml

keyboard_remote:
  - device_descriptor: "/dev/input/by-id/usb-HS6209_2.4G_Wireless_Receiver-event-kbd"
    type: "key_down"
    emulate_key_hold: true
    emulate_key_hold_delay: 0.25
    emulate_key_hold_repeat: 0.033

When listening to events in developer tool for keyboard_remote_command_received I see no events at all.

I have read through all posts that look like this fault with no idea what is wrong.

Looking at the permissions section in the docs, I have tried to type those commands in but get nothing I have tried a few other bits as well with no success.

If I type getfacl /dev/input/event* in terminal to see permission it says command not found.

So am I typing these in the wrong place, or they irrelevant?

Any other ideas why this might not be working?

Any errors in the log?
Also, see this note:

As far as I can see there are no issues in the log files, I will run another restart as soon as my esphome stuff has updated, just to check.

Checked the restart and no issues in the log.

Well after another restart it has started working.

No idea what’s happened, but hay thanks for any help.