Removed Mobile App integration

I removed accidentally the Mobile App integration, yes, I screwed up my config…

On 2 mobile phones the Home Assistant app was already installed, worked fine and still works fine even the ‘Mobile App integration’ doesn’t exist anymore in my config.

Problem is: I miss all my Entity ID’s for these mobile phones and as they don’t are there, I’m not able to integrate them in automations and so on.

In the docs I found this information https://www.home-assistant.io/integrations/mobile_app/ about the mobile app but it doesn’t help me.

I tried to restart Home Assistant, restarted both phones but I never got a notification that a new device was discovered. I believe I have to delete somewhere the existing links to the phone…

I found myself a nice workaround to solve the problem:

  • Create a new person with login credentials
  • Logout on your own mobile device and login with the above credentials
  • Yep, ‘Mobile App’ integration pops up with the ‘new’ registered device
  • Link the registed device to your own user (person) account
  • Remove the temporary created person.
  • Done

Sometimes live is easy, you only have to think out of the box…

P.S. You don’t have to change anything in the configuration.yaml, just be sure it contains:

default_config:

Cheers. Just found myself in this situation today. Over the course of 3 phone upgrades, due to restoring backups from each prior phone, my mobile app integration was still going by the name of 3 phones ago (although the individual entities had the name of the new device - maybe I had manually updated them?). So I saw this very old phone listed there and chose to delete it before realising it represented my current device.

Anyway, turns out you can just log out of the mobile app and log back in - no need to create a temporary user now.

1 Like