Removing default zone

During OS installation default zone was created. But for reason unknown to me, I can’t edit it. I tried to use override by setting Home zone in config file but it created additional zone instead of changing the default one.
How can I get rid of default zone? Or if that’s not possible, how can I change the radius for that?
The zone is called Dom so I tried both Home and Dom as a name in config file but in both cases it resulted in additional zone instead of overwritten the default one.

If you remove the latitude and longitude settings from your yaml (and restart/reload) you should be able to edit the home zone in the UI.

I don’t have anything zone related in the yaml right now. I was testing putting anything there but since it didn’t do anything good I just removed it. Also I can’t put zone in yaml without setting both latitude and longitude as they are required from what Check configuration says.

BTW By restarting/reload you mean whole HA instance or only zone config (Reload zones)?

Delete them from your yaml file along with any zones you dont want.

The home zone is centred on that lat & lon.

Once you have restarted (or reloaded Location & Customization) you will then be able to set a home zone (and radius) using the UI by setting the lat and lon there.

There wasn’t any entry from the very beginning. And I couldn’t edit Home zone, that was created during installation. Wiki says that I should use yaml in order to override settings for Home and that’s exactly what I wanted. I think the issue I was having here was because I was reloading Zones instead of Location & Customization. After fixing that my yaml config work as I wanted, which is lowering the radius. :slight_smile:
Thanks for suggestion!

1 Like

Got a link to that?


With 2022.12 release that now requires country: this is an issue for me. Base location is NOT in the zone options, but rather in the homeassistant section if you’re using YAML mode (or in the corresponding sections of UI).

So for me, I had to add data to configuration.yaml in the homeassistant section to correct my settings and identify country, and this may also help resolve the OP’s issue.