Repository: My Addons

I’ve created a couple of Hass.io add-ons for myself and gotten some ready for sharing.

I’ve got two addons here:

  • OpenVPN - I use this with Portmap dot io to expose my :8123 port install to the public internet
  • FireTV - For Amazon’s FireTV using the FireTV Component

To add my repo, follow instructions at Installing Third-party Add-ons and add https://github.com/greylurk/hassio-custom-addons

2 Likes

Hello.
I’ve just installed the openvpn addon.
How can i configure it?

Thank you!

I need to come up with a better way of doing it yet. The best I’ve gotten is to paste your openvpn config file into the left hand side of this tool, and the copying the result from the right side:

https://jqplay.org/s/yfgWAi-alI

I’m open to better options, I’ll probably take another swing at it this weekend.

1 Like

Hey @greylurk where do you storing the certs when configuring this? cheers

Hey @greylurk :slight_smile:

As @shindawg asked, where do you store the certificates? Cant get it to workshop with portmap io

You should just be able to use the .conf file from portmap.io (or any other openvpn server really) and just put it to the json configuration using the link on jqplay up above. I haven’t found a better way to encode long text files for configuration for an addon yet.

Is your OpenVPN addon referring to OpenVPN client or server? I’m looking for a way to install OpenVPN server on my Raspberry Pi 3 that is running Hassio, but I’m not familiar with the more restrictive setup of Hassio.

1 Like

I’d like to see this happen as well.
Are you aware of any further progress?
Thanks!

I’ve added the respository, selected OpenVPN under Greylurk’s Experiments, and clicked Install, but nothing appears to install. Any thoughts? Has this been broken by Hassio updates?

I’m not intending on turning this into an OpenVPN server addon, I don’t actually have a use case for that (or the expertise for writing it). I just wanted a client so that I could get around my somewhat unique firewall settings.

Has anyone looked at this: https://docs.resin.io/reference/resinOS/overview/2.x/#openvpn

OpenVPN

ResinOS will provide the user with an OpenVPN server that they might use. It is worth noting that this server will be disabled by default and manual interaction from the user is needed to activate and configure this server to their needs.

Can it be run on the Resin host?

@greylurk I’m in a similar situation, where my ISP’s double-NAT prevents me from accessing HA remotely. I’ve installed your add-on, set up a Configuration and a Mapping Rule at Portmap.io, downloaded the .ovpn file to my /config directory, and put that into the add-on’s config window. Unfortunately, it doesn’t work.

The add-on Log view shows generic setup options, so I don’t believe it is picking up my configuration file. Any ideas?

Section of Log:

Log
TLS Key Negotiation Options:
(These options are meaningful only for TLS-mode)
–tls-server : Enable TLS and assume server role during TLS handshake.
–tls-client : Enable TLS and assume client role during TLS handshake.
–key-method m : (DEPRECATED) Data channel key exchange method. m should be a method
number, such as 1 (default), 2, etc.
–ca file : Certificate authority file in .pem format containing
root certificate.
–capath dir : A directory of trusted certificates (CAs and CRLs).
–dh file : File containing Diffie Hellman parameters
in .pem format (for --tls-server only).
Use “openssl dhparam -out dh1024.pem 1024” to generate.
.
.
.

I am having the same issue, any luck?

No. The plug-in appears to start, but it isn’t connecting with the Portmap.io service (as confirmed by the portmap.io status and error logs, which show no activity).

Same here.

I finally figure out what was going on with this. The run.sh file has a typo.

the last line:
openvpn $(CONFIG_PATH)

Needs to be:
openvpn ${CONFIG_PATH}

I finally figured out where that file was locally stored, by editing the file and then rebuilding the container from the GUI the problem is resolved. It now appropriately opens a tunnel to portmap.io and I can access it at the portmap dns name and port.

I don’t have a GIT account so I haven’t logged this as an issue.

@greylurk, I have installed the addon, and it connects successfully. Thank you for your work on this, since I also have to use portmap.io

However, I have an issue where I cannot connect to Home Assistant through portmap.io on https./
I have portmap.io providing the https certificate and redirecting 443 ssl to 8123. I get a message “Unable to connect to Home Assistant.”

Have you received this error, and if so how did you solve it? Do you have any suggestions?