Repository: Nicholas Alipaz' Addons (dynamic dns)

This is my repository of addons. Currently I have only one but I think many might benefit and more may come as I find other needs.


Dynamic DNS client with SSL/TLS support - Similar to other clients such as the DuckDNS client or more generic clients like ddclient or ez-ipupdate this will update a dynamic dns entry with your public ip address. This can even be used in lieu of the DuckDNS addon since it is one of the supported providers.
0.1.10 requires 0.55.2 or higher

To add my repo, follow instructions at Installing Third-party Add-ons and add


A new release is now available. The newest release updates the schema so that it can now validate optional options in the schema. Due to the core addon schema system this was not previously possible.

0.1.10 requires 0.55.2 or higher


Looks great but I cannot figure out how to configure it. I’m using DynHost by OVH and the ddclient config looks like this:

# Configuration file for ddclient generated by debconf
# /etc/ddclient.conf

--domain name here--

Is it possible to use your addon ?



You might try something like this:

  "providers": [
      "provider": "dynhost",
      "custom_provider": true,
      "ddns_server": "",
      "ddns_path": "/nic/update",
      "checkip_server": "",
      "username": "",
      "password": "dyndns",
      "hostname": ""

Its still not working.

First error:
inadyn[19]: Failed creating pidfile: No such file or directory

Despite this error, it continues and then I get some weird errors like badsys or notfqdn.
Tryied using curl and URL:$HOST&myip=$CURRENT_IP, it works perfectly.

Is there a way do add a debug option and see what URL is called byt inadyn ?


Try changing ddns_path to be:

"ddns_path": "/nic/update?system=dyndns&hostname=%h&myip=%i",

I always get the pidfile error but it has never stopped it from working.

I tried some of this custom URL configs, and got the weird errors like this one:
inadyn[19]: Fatal error in DDNS server response:
inadyn[19]: [200 OK] notfqdn
inadyn[19]: Error response from DDNS server, exiting!
inadyn[19]: Error code 48: DDNS server response not OK

No debug option available ?

I did not add a way to set the verbose config option in the configuration file but will look into adding it in the near future. Too busy to do it at the moment. Sorry I don’t really have other suggestions other than to try to get into the created inadyn.conf file to see what is being written to it after you turn on the addon.

Hi, I’m trying to set multiple domain names with this, and have multiple entries in the provider list.

However when running only the last entry in the provider list gets updated, the others are silently ignored.

My bad…RTFM…I missed appending the :1 :2 etc to each provider name to get multiple entries for the same provider to be recognised. All now good!

FYI: I’m also using OVH dyndns, and I saw the generated inadyn.conf file was wrong:

by using “ddns_path” :“xxx”, the “&” in the path is converted to : “&” . Probably a bug in the module conf generation ? @nalipaz

Hi guys !

I tried something very stupid … and it worked perfectly !

Paste just that in your configuration :

    "providers": [
            "provider": "ovh",
            "username": "",
            "password": "yourpassword",
            "hostname": "thehostnameyouwanttoupdate"

You get some warning in the log, but the DynHost gets updated successfully !

Hope it will work for you too :slight_smile:

It does! Thx!

I guess I haven’t understood how to use the addon, but I got this from logs:

starting version 3.2.2
inadyn[17]: In-a-dyn version 2.2.1 -- Dynamic DNS update client.
inadyn[17]: /usr/local/etc/inadyn.conf:6: Invalid DDNS provider namecheap
inadyn[17]: Parse error in /usr/local/etc/inadyn.conf
inadyn[17]: Error code 74: Missing .conf file

… and this is what I put in my config …

  "providers": [
      "provider": "namecheap",
      "username": "******",
      "password": "********",
      "hostname": ""

What it mean for Error code 74: Missing .conf file?

Added the repo as stated, got the following error:

ERROR (SyncWorker_10) [hassio.docker.interface] Can’t install nicholasalipaz/armv7-inadyn:0.1.11 -> 404 Client Error: Not Found (“pull access denied for nicholasalipaz/armv7-inadyn, repository does not exist or may require ‘docker login’”)

HassOS 2.10 on raspberry pi 3 B+

I tried to install the addon but I get this error:
19-04-09 04:15:31 WARNING (MainThread) [] Can't read /data/addons/git/85933338/inadyn/config.json: required key not provided @ data['arch']. Got None

I am running hassio on Docker Windows.

I added “arch”: [“amd64”], to the config.json and it worked :no_mouth:

Same error, but if I log via SSH the file does not exist… Is it outside the container ?
Using HASSIO also…

The addon was working, but stopped updating.
Seems the problem could be with the provider, right ? (spdyn)

starting version 3.2.2
inadyn[13]: In-a-dyn version 2.2.1 -- Dynamic DNS update client.
inadyn[13]: Guessing DDNS plugin '[email protected]' from ''
inadyn[13]: Failed creating pidfile: No such file or directory
inadyn[13]: Failed to get IP address for [email protected], giving up!
inadyn[13]: Update forced for alias, new IP#
inadyn[13]: Fatal error in DDNS server response:
inadyn[13]: [200 OK] 
inadyn[13]: Error response from DDNS server, exiting!
inadyn[13]: Error code 48: DDNS server response not OK

Can you help me configure dynamic dns for below.