Requiring almost constant zwavejs addon restarts to keep network up

I have around 120 zwave devices. Was using a 700 stick with the latest firmware and network kept going down.

Started completely over with a Zooz 800 stick and have added most (115) of my devices back. Without security this time. Network was pretty reliable. A few devices dropping that would come back with a ping.
I updated the stick firmware to 7.19.3 a couple days ago and back to the same behavior as with the 700. Network is unusable.
If I restart the addon everything comes back for a little while but then the devices go back to unresponsive.
The only other thing done was the OS update for HA that I took after the firmware update. Should have waited on it to avoid too many changes but didn’t.

I don’t look forward to starting fresh again (just to have it repeat) so would appreciate any help to track this down.

Once it goes down, pings fail (error). I just tried a soft reset/restart and that worked as well. I did that and was immediately able to do a ping and bring the device back.

How can I get further information on what’s going on that might help someone?

What is in the logs? Is it timing out and retrying for certain devices?

I’ve found that I had one smart plug that used to constantly fail, and stuff that randomly routed through it would fail. Once I removed that one plug from mesh, life got much better.

Which log should I parse through? I always get lost on which I should focus on for zwave issues.
I have been emailing Zooz support and asked if I could downgrade. They sent me a file to do so but turns out there was an early batch of their 800 sticks with a bad bootloader that caused issues - mine is one of those. They are sending me a 7.19.3 new stick so I will do an nvm restore on it and see what happens.
There has to be some compatibility issues between the hardware and software that is causing it to get in a bad state.

  1. Soft Reset of the stick fixes it immediately - would indicate hardware.

  2. Restart of zwavejs ui add on fixes it immediately - would indicate software.

So what do both of these action have in common? Clearing a cache?

That’s cool they are sending a new one. Hopefully that addresses it cause the logs can be rather verbose and a bit of a PITA to go through.

1 Like

Is the stick on a powered usb hub with extension?

It’s on a 15ft extension but not powered by itself though I think the cable has the capability. I did test it directly connected to the desktop to see if it had an impact and it didn’t so I moved it back.
It’s been on this extension for the entire time (minus the test) and didn’t show this widespread issue until the fw upgrade. So I don’t suspect the extension has anything to do with it but may start doing more tests including changing that around if the new stick doesn’t fix it.

I’ve been holding off posting to see if anything changed as well as I didn’t want to jinx myself.

I got the replacement that was supposed to 7.19.3 but with the ability to downgrade.
I backed mine up using SiliconLabs, plugged the new one in and tried to restore. Success message but no nodes. Originally it had shown 1 for the controller I assume but after the restore, nothing. Well awesome.
I tried again a few times and even tried to flash the firmware again on it. No dice. Still no nodes.
I figured everything was trashed anyways (since my original stick wasn’t working right as per this thread) so I stopped the zwave integration and plugged the ‘new’ stick in. ZwaveJS wasn’t able to find it at all. No surprise. Rebooted HA, rebooted my server running the vm, nothing.
Turned the server off, plugged the old stick (no changes had been made to it) back in, and turned everything back on.

Hate to even say it out loud but it has all been working spectacularly for a couple weeks. Don’t know how or why but something obviously got reset. I may have the odd device go dead and need a ping but it’s really been pretty rare and the command response time has been great.

The stick is SDK 7.19.3 and FW 1.2

What’s the host platform hosting HA? I had similar issues on my RPi4 until I added a powered USB hub from Best Buy, solved all my issues. I’m using a ten foot USB extension cable as well to get the Zooz 700 Series USB Stick away from the RPi4 for better reception.

Windows 11 using Virtual Box. It’s on an extension cable (see two posts above yours) and that never changed. Very odd stuff :slight_smile: