Restoring RPi Backup on VirtualBox HA instance


I have a RPi 3B+ running the latest HA. I am still figuring things out. I setup local tuya and after all this work, I wanted to test the backup/restore function, in case something happens to the RPi or installation. I installed virtualbox on a Windows 10 mini PC with 3 CPUs, 2GB RAM and the HA vdi image. I plan to use this PC in the future, instead of the RPi.
I tried to restore a full backup from the RPi on the unconfigured VB machine via the restore button on the onboarding page, but all custom dashboards, local tuya and all other devices are missing/not configured.
I then configured a fresh HA instance with HACS and local tuya and the add ons I have on the RPi and tried to restore the backup again, but still no dashboards, no local tuya and no devices.
Am I missing something or is it just not possible to restore across architectures?

Since no one ever answered, I tried again today. Restoring a full backup from the RPI does exactly nothing. At the onboarding stage, nothing happens and after creating a user and trying to restore again, the connection is lost and regained, but nothing is ever restored. I now installed the samba add-on on both instances and copied the complete config folder (including hidden folders) from the RPi to the VM.
After a reboot, the VM shows all my installed addons, users, HACS, local tuya, etc. It complained about the missing bluetooth device and the RPi power sensor, but that was all.
I still have to switch the from the Rpi to the VM, changing the IP and all, but that has to wait till after christmas.
I still think backup and restore should work reliably, considering the time that goes into setting everything up.