Retrigger discovery for xiaomi ble device

I have a few MiFlora plant sensors (HHCCJCY01) but recently a couple of them are reporting sensors as unavailable permanently. For those ones I was trying the old turn-it-on-and-off trick, first by restarting the devices themselves (remove battery, wait, replace battery) but this didn’t make any difference.

I then tried to remove the config entries from HA in hopes of readding the devices, however, after removal the devices do not show up in the discovery section of HA and I can’t seem to trigger discovery in any way nor manually add the devices to the Xiaomi BLE integration.

Is there a way to manually trigger Bluetooth discovery OR to manually add a Xiamoi BLE device? I suspect the issue is that the device was already “discovered” by HA - any way to reset this?

I’ve tried restarting HA, rebooting the OS, and even deleting and re-adding the Bluetooth integration - to no avail.

Thanks for any help!

do you solve this problem?
i have 2 device bought in aliexpres (white version) and one apears in autodiscovery but desapears after some days, and the other not apears never :frowning:
edit, 6 hours later the integration apears (HHCCJCY01) but not entities, only the device. :frowning: