Rflink NewKaku remote code problem (AYCT-102)

Hi guys,

I want to use RFLink to control some of my led lights (KaKu) in my terrace roof.
So i connected my RFLink to my pc via usb and started RFLink Loader to collect some data.

I started serial port logging and pressed “on” on the remote what resulted in this:


Also when i press “off” on the remote


Cool, now lets try some commands:


Resulted in lights that goes on


Here is where the problem occurs, nothing happens. The lights don’t go out.

What can i do?

Sometimes you have to repeat a command.

I did try that, but it didn’t work. Also in home assistant i can only switch on the light. When i switch off the light it shows “on” in debug.

There are 2 different behaviors to analyze.

  1. RFLink connected to the PC:
    From the traces you attach, I don’t see any reason why the bulb cannot be turned off. My only advice may be to double-check that the ON / OFF signals from the remote have both the same ID and SWITCH code. It’s the only thing I can think of.

  2. RFLink integration in HA:
    RFLink integration in HA allows you to configure the light type attribute:

  • RFLink Light - Home Assistant
    By default, NewKaku lights have the type hybrid, but the behavior described seems to indicate that the type toggle is used here.
    In any case, if you can’t make it work with the RFLink connected to the PC, it won’t work from HA either.

It can be a new device type not yet supported by RFLink?
The supported devices list can be checked here:

Hi there, thanks for your reply!
These are the codes that RFLink send back when i press ON/OFF on the remote:



As you can see they DO have the same id’s.
And yes i used the toggle mode in my config, will change it to hybrid in a minute, but as you are saying if it’s not working in RFLink Loader it won’t work in HA either.
I’ve send a few mails to frank zironne, he says he is using the same remote without any problems (AYCT-102) but he is responding very slow to his email!
I also tried the RFfind function, but it’s not working with this type of remote.

Although the problem may be related to the remote (AYCT-102), it may be possible to search for a signal that works for the device you want to use (the led lights). Let me explain.

It seems clear that RFLink recognizes ‘a’ signal from the remote, and that it does not work from RFLink.
But maybe you can emulate from RFLink another signal that the target device does recognize. You will surely have to pair the new signal to the device you want to control, but it is another way to explore to make it work.

How exactly do you want me to do that?
I’ve tried for example 10;newkaku;01e38bfa;1;OFF; and so on, if that is what you mean. Because i saw a youtube video where the “off” signal is a bit higher then the “on” signal.

The point here will be to pair a new ‘remote’ (a RFLink switch) with your target device.

In order to do this, you must create a totally new switch in HA, for example:

   - platform: rflink
         name: My New Switch

Then you must use this new switch (from HA) to pair with your target device. Pairing a new device with the target will allow you to control the device in both ways (the physical remmote and from HA).
Check the manual to know what the device pairing process is. Usually requires pressing a button in the target device (the led strip) for a couple of seconds.

Tnx for your reply!
Indeed i can pair a new switch as you mentioned!
As it is paired, i can only turn the lights on via HA. So, i’m still facing the same issue.

So, it seems to be a compatibility problem with the receiver, could you tell us which device it is?
Is it a led+remote pack that was already paired when you bought it?

That’s correct.
It’s a ACM-1000 with this leds.
And yes, it was paired by the company that build this thing in my garden.

I don’t see any reason why it shouldn’t be working.
The receiver has been reported working with RFLink and you have tried different RFLink codes…

Would you be so kind as to include your RFLink configuration? (the integration part and the switch part)

On the other hand, which button (or buttons) do you use on the remote to switch the lights?

  - platform: rflink
    automatic_add: true
  - platform: rflink
        name: Lampen Overkapping
        type: switchable

Ummm, there’s something wrong here…

It’s expected to have an integration part like:

  port: /dev/ttyUSB0
  wait_for_ack: false

and the switch/lightpart like:

  - platform: rflink
    automatic_add: true
        name: Lampen Overkapping
        type: switchable

In any case, I can’t think of any reason why it shouldn’t work.

Do you think it’s the receiver? If i buy an ACM-2000 for example, that it will be fixed?
Forgot to mention the “port” part.
Somfy is working great with RF.
Maybe I’ll buy the ACM-2000 this week.

I do not know what to tell you. If I do not understand the reason why the ACM-1000 does not work, I cannot say if the ACM-2000 will work.