RFXCOM 11 working covers and now 2 new

Tags: #<Tag:0x00007f3263129480>

Hi Guys,

I’ve installed Home Assistant for over half a year.
One criterion for HA was the integration of RFXCOM RFXtrx.

This integration worked wonderfully right from the start with 11 Somfy RTS roller shutters. I even managed the changes with version 0.113 well.

Now I wanted to integrate two roller shutters that previously had no power supply.

The shutters got their Somfy remote control, they are programmed and I gave them IDs via the RFXmngr.

The configuration in the configuration.yaml looks like this:

rfxtrx:
  device: '/ dev / serial / by-id / usb-RFXCOM_RFXtrx433XL_DO32OE2X-if00-port0: 38400'
  devices:
    071a000003140A01: #RFY
    071a000003150B01: #RFY
    071a000002010101: #RFY
    071a000001140101: #RFY
    071a000001150101: #RFY
    071a000001160A01: #RFY
    071a000001171A01: #RFY
    071a000001181A01: #RFY
    071a000001191A01: #RFY
    071a000001202A01: #RFY
    071a000001212A01: #RFY
    071a000001220101: #RFY
    071a000001320101: #RFY

The first two IDs (071a000003140A01 and 071a000003150B01) are the added shutters.

Both are not accepted by the integration. They do not appear as devices.

Does somebody has any idea? Before 0.113 the integration was based purely on the entries in the configuration.yaml.

regards
Oliver

Hello, does anyone have any idea why the new devices in the configuration.yaml are ignored?

Thanks for your help

Oliver,

check the ID of your devices.
I see that the ones that are not accepted are starting with 000003. change those to 000001
I think they all need to be with 000001

greetz

Hello,

I was able to solve my problem.

In the meantime I had deleted the integration and then all my shutters were gone. The information in configuration.yaml that had worked up to that point no longer had any influence.

To the solution:
I did not understand the integration introduced with 0.113. In the integration there is the input field “Enter event code to add” under Options. I translated into German that I should enter a code here to trigger an event to add a device. I did not find such a code in forums or in the documentation.

Since all the roller shutters were no longer working anyway, I just tried to enter the ID of a roller shutter there. That was exactly the solution. The roller shutter and all its entities were added with each ID.

If the input field were marked with “Enter the ID of a device to add”, then I would have understood that from the start.

Nevertheless, thank you for your support.
The thread can be closed.