RGBWW How to turn on White led using Device Service Light -on

service: light.turn_on
target:
device_id: 623fc5828d963d2e194639ee44f890ea
area_id: drive
data:
brightness: 173
transition: 1
rgbw_color: 0,0,0,255

All outher colours are working but my attempts of white give “None for dictionary value @ data[‘rgbw_color’]. Got None” What have I got wrong ?

site:home-assistant.io turn on white in an rgbww

Put that into your search engine. Lots of good info here on the site already.

Many thanks, have looked around a few of the conversations previously on this subject but your url took me to some further posts. It looks like there is no one perfect answer. I eventually got it to work by using RGB channel and brightness in the Shelly light switch integration, but it is not clean.

1 Like