Roller blinds automation problem

Hello guys!

I recently installed z-wave blinds and made an automation where it goes up at 10.15 each morning.

My question is now, how do I get it to get down at 23:00 every day?

Here’s how my yamal looks like:

automation:

trigger:
platform: time
at: “10:15:00”
action:
- service: cover.set_cover_position
data:
entity_id: cover.level,cover.switch
position: 0

It looks very much like you have all the building blocks to working this out yourself, but to nudge you in the right direction…

You can either set a second automation that triggers at the other time, with the action adapted to close the blind, or you can add a second trigger to the existing automation and use a template to decide whether to open or close based on the time of day.

I have tried several ways but I always get “contains duplicate key”

for example, like this:

automation:

trigger:
platform: time
at: “10:15:00”
action:
- service: cover.set_cover_position
data:
entity_id: cover.level,cover.switch
position: 0

automation:

trigger:
platform: time
at: “23:15:00”
action:
- service: cover.set_cover_position
data:
entity_id: cover.level,cover.switch
position: 100

I have also tried to give different names in different places and tried to check out others’ automations but I do not understand wha’st interrupting

You need to ‘list’ multiple automations, should look like this…

automation:
  - trigger:
      platform: time
      at: “10:15:00”
    action:
      - service: cover.set_cover_position
        data:
          entity_id: cover.level,cover.switch
          position: 0

  - trigger:
      platform: time
      at: “23:15:00”
    action:
      - service: cover.set_cover_position
        data:
          entity_id: cover.level,cover.switch
          position: 100

Okey thank you!

got this massange:

Invalid config for [automation]: Invalid time specified: “10:15:00” for dictionary value @ data[‘trigger’][0][‘at’]. Got None. (See /config/configuration.yaml, line 81). Please check the docs at Automation - Home Assistant
Invalid config for [automation]: Invalid time specified: “23:15:00” for dictionary value @ data[‘trigger’][0][‘at’]. Got None. (See /config/configuration.yaml, line 81). Please check the docs at Automation - Home Assistant

Could it be due to wrong spaces?

Unless it’s a side effect of cutting and pasting, it looks like maybe you’re using the wrong kind of quote characters. It has to be either single quotes, or double quotes, but not fancy, word processor type curly quotes. I.e., this:

  ...
  at: '10:15:00'
  ...

or

  ...
  at: "10:15:00"
  ...

but not

  ...
  at: “10:15:00”
  ...

that’s right, now it works! Thanks for the help!