Rpi 3 doesn't boot

Hello all,

I have rpi3 and have flash the 64bit image as per the manual. When I put the card in the rpi and try to boot the red light stays on (so there is power) and the green light will blink 2-3 times and will be stay off after this. The network port light didn’t blink. I have the rpi connected to a monitor. After I start the rpi the monitor will switch on but it will be just a black screen and will not go in power saving mode until I stop the rpi.

Raspberry Pi OS Lite boots without a problem, so the rpi and the card are working as expected.

Any suggestions what the problem could be?

Are you sure you took the RPi3 64bit image, and not the Rpi4 64bit image ?

Yes, I’m sure. I have tried with the rpi4 image and with it the green light will be constantly on and the monitor will stay in power saving mode. Just have tried with the 32bit version and it’s the same behavior - red light on the the green will blink 2-3 times and will go off.

I have tried with older images and the only change is the number the green light will flash is different but never more than 3 times.

Hi!, Did You solve it? I got the exacly the same problem… I’ve check everything. No problem on rpi4(with right file for it), cant boot rpi3 B+(32 and 64bit version, right file)

Any update on this issue? Just tried to push the Rpi3 64 bit OS to my Rpi3 and I am getting the same results. Solid red led and no network lights. Found the older releases and the latest unstable version in github and same results.

sorry, nobody answear, i searched over internet, many has problem - nobody knows why