Ruckus Unleashed - SSH Problem?

Trying to get the Ruckus Unleashed integration to install in my HA setup.
I am getting an “unexpected error” and I suspect it’s because my HA can’t connect via SSH, as per the integration’s instructions. I’m pretty confident I’ve followed the steps ok, but I’m clearly missing something.

When I try to verify that HA can SSH into the Ruckus AP, I get an error message saying “unable to negotiate with [IP] port 20: No matching host key type found. Their offer: ssh-rsa”

Note that I am also in the process of upgrading from R500 to R710 units. So the first IP was tried with the R500 as the master unit, then i took the R500 units (x2) offline, and left only the R710 units online and tried again with the new master IP.

I can successfully connect via putty though
putty ok

So I’m at a bit of a loss.
Here’s the rest of the config. It’s pretty straight forward from what I can tell.

R500 & R710 units were running unleashed firmware.
I’m upgrading the R710 units now that they’re the only ones online. I’ll try the newest firmware for the R710 ( but I doubt it’ll make a difference.

Anyone have any insight to help me??

googled around some more and found a command " ```
ssh -oHostKeyAlgorithms=+ssh-rsa

What version of HA are you running? This was a problem with 2023.7, 2023.8 and IIRC 2023.6… It’s been fixed in 2023.9

I am on 2023.6 currently.

That’s good news then, I was planning on catching up on some updates so hopefully that will fix it.

Yup - That fixed it. Updated to 2023.9.2 tonight.