SAJ Solar inverter

nope thats my laptop IP trying to connect to EW11

Confirm this works on the RS485 (but i had to remove my SAJ SEC consumption monitor which uses that port) - can this port be split?

On the RS232 still getting the same error - i found a document when shows the error in qmod and suggests using a script?

Elfin-EW11A-Eniris-comments-and-application-guide-1.pdf

Hi, trying to get my new SAJ HS2 (HS2-3K-S2) to communicate but it won’t.

I have an eSolar AIO3 that calls itself “espressif” (hello esp32!) with a local Wifi IP address that I can ping, but sudo nmap 172.17.2.139 shows no ports open, neither can I connect to tcp/502. I even tried nmap with -p- but no high ports open, either.

Firmware version says v1.027, Hardware version v1.001. Connecting to an ethernet cable because I can, but no open ports either.

Then I tried the RS485 port. The inverter has two of them, marked “Meter/EMS”, both are connected to the same RJ-45 plug. I have a Waveshare RS485 to ethernet thing that should serve this purpose.

I also have an oscilloscope. The RS485 line at the HS2 shows some traffic - very noisy, so I’m hoping the Waveshare thing will know what to do. It’s 9600 bps and (which is what the HS2 “RS485 settings” in the app say, too) The inverter seems to want to say 0x01 0x03 0x20 0x00 0x00 0x10 0x4F 0xC6 repeatedly and Internet tells me the inverter wants to read register 0x2000. When I set the Waveshare to “none” instead of “modbus TCP”, the 0x0103200000104fc6 sequence is the exact outcome of a connection to port 502. Unfortunately, whatever I say to the SAJ H2 Inverter Modbus HA module, the H2 doesn’t say anything else.

So what am I doing wrong? (And why wants my inverter to read register 0x2000?)

I was actually hoping the SAJ machinery would work out of the box, having the protocol nicely documented and such…

OK, I’ll reply to myself. I managed to get the communication working, by removing the AIO3 and connecting a serial cable. I’ll document the connections (but ping me if I haven’t).

Now I can communicate with the H2 through home-assistant - and also with “mbpoll”, a Linux utility to use Modbus. For example, mbpoll -a1 -t4 -0 -1 -r $(( 0x3675 )) -p 23 172.17.2.210 0 turns off the lights (ring and status LEDs) at the H2, mbpoll -a1 -t4 -0 -1 -r $(( 0x3675 )) -p 23 172.17.2.210 3 turns them on again.

Is there a LimitPower setting for the SAJ H2 inverter, like the one for the R5 inverters (0x801f)? I cannot find it in the modbus documentation. There are a few “AntiReflux” powerlimit settings, but they don’t seem to limit output power. (Also, their sizing seems a bit weird, 0 - 1100 with a scaling factor of 3?)

Replying to myself once more: yeah, there is such setting! It has a weird name: when I change the 0x3650 register, the power output changes. The register is called GridDischarchePower, Grid max discharge power, and it is a percentage setting that is advertised as times 0.001 (i.e. 10⁻³) and as a percentage going from 0 - 1100. The “1100” setting most likely means “not active”, the O&M app will not let you set it to 110%, but the serial port (with modbus) will.

The 10⁻³ factor (or ratio as the SAJ documents call it) is a bit confusing, but it’s rather easy once you understand that 1000 means 100% (or 1.00), 500 means 50% (or 0.500), and 1 means 0.1% or 0,001, hence the “times 0.001” factor.

Setting the percentage lower than 100% means “Maximum output power as a percentage of maximum inverter power”, so a 3KW inverter will output 1500W max if you set GridDischarchePower to 50% (putting 500 in register 0x3650).

@stanus74 this means that the SAJ H2 component can have a limitpower function too, and it should be as easy as self._write_registers(unit=1,address=0x3650,values=int(value*10)).

Please note that I’m not a modbus specialist, by far, but I noticed that there is some confusion about addresses, starting from 1 on the protocol and from 0 on the wire. I’m using mbpoll -a1 -t4 -0 -1 -r $(( 0x3650 )) -p 23 172.17.2.210 500 to set my inverter to 50% max output: this is “register 0x3650 starting from 0” (" -0 First reference is 0 (PDU addressing) instead 1" is what the mbpoll documentation says.)

I do, can i use 2 inverter with one meter

I have two H2-10K-T2 with two bateries connected to one inverter, i wanna know how to use one meter with two inverters, can somebody help me