Scenes with Homematic Climate

Hi,
i will move my automations from NodeRed to Homeassistant.
Now, i have create a scene “All Radiators off” and put some Devices “Homematic Climate” in this Scene.
After that, i change the tempature in this Scene.
Now, after some Minutes, the DutyCycle will increase to 99% on my Raspberrymagic CCU.

If i remove the Scene and reboot the HomeAssistant Server, then the DutyCycle will decrease to 13% after a short time.

If i configure a new scene with one Homematic Climate and activate this scence no changes are made to the Device. But the DutyCycle is increase to 22%…

Latest HASSIO
latest Raspberrymagic on a pi3
Homematic COnifguration with resolvename json

If i delete the scene and reboot hassio all working fine and i can change the HM Device without Problems.

Can someone help?

Regards
Herbert

Hi,
has anyone else Homematic Clima devices in a scene?

Does that work for you?

Hi.
I am also in the process to move more automation from Node-RED to Home Assistant.
Installation: 6 thermostate in 5 rooms + 1 controller (and window sensor, smoke detector, …)
To switch between different week profiles and manu/auto mode I use a combination of Node-RED flows and scripts (Climate All Set Week Profile, Climate All Set Mode Manu, …)

Works fine so far. Dutycycle is at 7 to 15%

Hi Herbert
I gave up on scenes and did it in a different way:

  • On the Raspberrymatic (now an addon within Home Assistant) combine all window sensors, wall thermostats and radiator thermostats of a room into a group.
  • Then set the preset temperatures of each group to sensible levels (e.g. 18, 20, 22 °C) for the whole day, the whole week (Wochenprogramme). No timer or anything (00:00 Uhr - 24:00 Uhr & Temperaturprofil X wie am Vortag).
  • In Home Assistant → Configuration → Helpers add a number. In this example “bathroom_heat_level” with mdi:shower (optional icon), Minimum value = 1, Maximum Value = 3, Display mode = slider, Step size = 1. Leave “Unit of measurement” empty. You could give that slider a friendly name later.
  • Configuration → Automations create a new automation and switch to YAML mode (three dots in upper right corner) and use this automation:
alias: Bathroom Apply Heat Level
description: ''
trigger:
  - platform: state
    entity_id: input_number.bathroom_heat_level
    for: '00:00:10'
condition: []
action:
  - service: climate.set_hvac_mode
    data:
      hvac_mode: auto
    entity_id: climate.int0000003
  - service: homematic.set_device_value
    data_template:
      interface: groups
      address: INT0000003
      channel: 1
      param: ACTIVE_PROFILE
      value: '{{ states(''input_number.bathroom_heat_level'') | int }}'
mode: restart

If bathroom_heat_level is set to a value for at least 10 seconds this automation will trigger and turn “Boost” off by setting the hvac_mode to auto. Then the level (Wochenprogramm) will be set. Change int0000003 to you group number(s).
You may still change the temperature on the thermostats and in by adjusting the lovelace ui thermostats but it will not be reflected by the helper or this automation. The temperature will be reset at midnight to the defined “level” that was set. But that didn’t bother me.

I did this for all of my rooms and it works fine. No Duty Cycle issues.
Use input_number.bathroom_heat_level wherever you want to influence the temperature of the bathroom instead of setting the temperature directly.