Scripts are not displayed in Google Home

I wrote this configuration and all my devices are explained to me, but for scripts nothing to do where am I wrong?

# Google Assistant
google_assistant:
  project_id: homxxxxxxx
  service_account: !include HomeAxxxxxxxxxjson
  expose_by_default: true
  exposed_domains:
    - light
    - switch
    - climate
    - script
  entity_config:
    script.luce_salotto:
      name: Luce Salotto
      expose: true

If you go into Home Control they will be listed under scenes… mine are all there. Your config looks ok. I don’t expose any domains by default and list all entities.

thanks failed to find them finally.
But there is a problem if I put the command “turn on living room light” it can’t find it, if I say “activate living room light” it works perfectly.

Advice?

Yeah has to be activate or you can define routines so you can say whatever you want to. OR… if it’s a script to turn on a light, use an automation triggered by the state of the light so it will execute the script actions and you can say turn on the light…

basically the script just executes this http command:

GET http://139.59.206.133/xxxxxxxxxxxxxxx/update/V1?value=1

I have no state. if i run it turn on the light and rerun it turns off the light. It does the function of a classic mechanical relay

You could set up an input_boolean… I use those with GA…??

I was thinking about it, but still the status remains out of date. example if the light is already on and I want to turn it off with the voice command it turns off but then remains active on HA

I don’t understand then. Scripts don’t remain on or off so how does HA show the light status? If that is some other entity why don’t you expose that to GA? Confused…