Secrets cause a max recursion error

Problem:

Failed to call service automation/reload. maximum recursion depth exceeded

This occurs anytime I try to read a value from my secrets.yaml file. There is only one in my root config directory.

Backstory:
System was functioning fine via a VM running hass ontop of ubuntu server. I was carving up my lovelace file to help make it more readable for me. Nothing crazy. After a power failure on my laptop hosting the VM I rebooted and homeassistant would not load.
After much aggravation I just decided I’d blow away the db and start over - this is still all in test phase anyhow. After that and a replacement with the stock configuration.yaml file. It boots again.

So I try working my previous setting back in one at a time to see if I can pinpoint were my implosion occurred. I first modify my config to:

default_config:

homeassistant:
  name: Ragged Jack Mtn
  latitude: 44.419597
  longitude: -70.411688
group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

All is good after a config check and even a reboot as would be expected.

With my secrets.yaml file like this:

# Home Assistant
ha_latitude: 44.419597
ha_longitude: -70.411688
ha_elevation: 454.506072
ha_time_zone: America/New_York

Now I try:

default_config:

homeassistant:
  name: Ragged Jack Mtn
  latitude: !secret ha_latitude
  longitude: !secret ha_longitude
group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

results in an infinite loop, but if I try to, say, reload my automations I get the following error:

Failed to call service automation/reload. maximum recursion depth exceeded

I reverted my lovelace breakout back into a single file for no change.