Sensibo Climate Switch

Hi I got the Sensibo Sky To control my Ducted. Heater/Cooler.
It works great.
Configured as per the Integration instructions as beow.

climate:
  - platform: sensibo
    api_key: *my_secret_key*

switch:
  - platform: template
    switches:
      ac:
        friendly_name: "AC"
        value_template: "{{ is_state('climate.ac', 'cool') or is_state('climate.ac', 'heat') or is_state('climate.ac', 'dry') or is_state('climate.ac', 'fan_only') }}"
        turn_on:
          service: climate.set_hvac_mode
          data:
            entity_id: climate.ac
            hvac_mode: cool
        turn_off:
          service: climate.set_hvac_mode
          data:
            entity_id: climate.ac
            hvac_mode: off

The above code is making my AC turn on randomly, guess its the value template section. I dont want any automation making it to turn on, Automation i would want is to turn it off when every one leaves the house. or Turn off after reaching a certain temperature.

I need:

  1. I need a simple Toggle switch to control.
    When i click on the switch.ac
    The error i get is.

Failed to call service switch/turn_off. value is not allowed for dictionary value @ data['hvac_mode']

  1. Entity shows: This entity does not have a unique ID, therefore its settings cannot be managed from the UI. in the description.
    i tried to add id:1 but that didnt work.

  2. My Google home is integrated, so i enjoy turning switches on and off with voice. Is there a way i can say Hey Google Turn on the heater = and the sensibo switches on the remote+adjusts the temperature to 30. and when say Hey Google Turn on the Cooler = and the sensibo switches on the remote and adjusts the temperature to 18.

I know i requested a lot, so thanks for your patience and Thank you so much in advance.

I’m pretty new to this myself so take my suggestion with a grain of salt - but the configuration page for sensibo looked odd to me as the indication for turn on used turn_on.target.hvac_mode and the turn off used turn_off.data.hvac_mode. Moving the hvac_mode inside turn_off from data to a separate node target worked for me - you can try it too.