Sensor data is not changing

I have a MySensors device. It sends battery voltage, humidity and temperature to HA. The temperature data is not changing, but the humidity and battery voltage are.

I can see the voltage data change on the device as it is sent to the MySensors Gateway. I can see the MySensors Gateway send the voltage data to the MQTT broker. I can see the voltage data on the MQTT broker. And finally, I can see the voltage data on HA using Studio Code Server.

But the voltage data does not get to the HA database config/home-assistant_v2.db and it does not appear in the card on the Dashboard and it does not appear on the device (Settings–>Devices & Services–>n_devices (mqtt MySensors)–>sensorName 130

The other data, battery voltage and humidity, do change.

Home Assistant 2023.5.2
Supervisor 2023.04.1
Operating System 10.1
Frontend 20230503.3 - latest

What’s the problem and how do I fixit?


Here’s what I found out and wrote in Discord:

My network went haywire when my ISP did an update. I discovered that ASUS routers have a memory leak when many WiFi clients try to connect at the same time. The fix for that is to remove power from the router! The lack of a router causes HA to freak out., thus requiring HA to be shutdown. I am uncertain that deleting the data in the MQTT broker helps, but it doesn’t hurt. MySensors Gateway has to then be stopped and restarted after HA has completely started. The problem of today is a result of my not waiting long enough. Prety much, don’t do anything until the MQTT topic Homassistant/status = online

My experience is that if HA is not shutdown and then restarted (as opposed to restart) parts of the device “linger” Also, waits are very important. It seems that the triggers of the topics to which HA subscribe don’t happen. That is, HA has to be fully on board with MQTT before trying to send data to the topic of interest.

The logs were complaining about a duplicate child sensor. I reinstalled the device. In the MySensors world, the procedure for reinstalling a device is: 1) power off device (wait 30 seconds) 2) delete the device from HA: settings–>Devices&Services–>N_devices(under MySensors)–>devicename–>DELETE(under Device Info) (wait 1 minute) 3) Shtdown HA: settings–>System–>(power button upper right)–>Advanced options–>Shut down system (wait 2-5 minutes) 4) Stop MySensors Gateway 5) using MQTT explorer, remove all topics pertaining to the device on the MQTT broker 6) start HA (wait about 2-5 minutes) 7) start MySensors Gateway (wait about 30 seconds) 8 ) start device (wait 1 minute) It should be found again