I have a Zooz Zen17 zwave relay connected via ZwaveJS to Home Assistant. Every time the zwave device restarts, ZwaveJS restarts, or Home Assistant restarts, the sensor entities are renamed.
For instance, they go from:
binary_sensor.gate_relay_window_door_is_open_2
to
binary_sensor.gate_relay_window_door_is_open_2_5
The original entity shows as “unavailable” and the new entity is now the one that updates from the relay. I can rename the entities to their original name and delete the now duplicate entity, but it every time either device restarts, the entity is renamed.
This device has 2 relays and 2 sensors. It only happens to the relay entities, not the sensor entities.
I have a raspberry pi with a homeseer zwave hat connected to it and zwavejs installed. Home assistant is connected to the raspberry pi via the zwavejs integration from Home Assistant.
This may help you figure out what is happening. I haven’t seen this happen with only a restart, but Home Assistant is discovering a new device and since the name already exists, the suffix is added.
Of course it’s a software issue. The automatic suffix is a particular pet-peeve of mine. I do a lot of experimental work using ESP devices and ESPHome and - without any logic - sometimes a device will gain a new suffix, frequently screwing up automations or scripts. I wouldn’t mind if Home Assistant interrupted my workflow to warn me that “a device named xyz already exists, is this a new device?”.
Try to reduce your testing protocol to determine how anyone else can reproduce the issue.
Wait, what? What is a “ZwaveJS box”? I have 14 Z-wave devices in my home, and I’ve never heard of a Z-waveJS box.
I made it myself. Raspberry Pi 3 + Zwave Hat + ZwaveJS installed. It natively integrates to Home Assistant. Had to do that because this is at a gate a half mile away from the house.
Just wish I could get the entities to stay the same.
See link below. The one I care about and the one that keeps getting renamed is binary_sensor.gate_relay_window_door_is_open_2.
Note the ones called “gate_relay_window_door_is_open_2_x” and gate_relay_window_door_is_open_2_xy" are ones that I renamed myself because they were the old sensors that were renamed and I could not delete them so I had to rename them to something unique that way I wouldn’t have two entities with the same name.