Sensor Group from single MQTT with JSON

Hello all
I have a server a thome that his outputting a JSON array of temperature sensors, like this:

{
  "Readings": [
    {
      "unit": "C",
      "status": "'OK'",
      "sensor_type": "Temperature",
      "temp": "27.00",
      "Type": "Temp 1",
      "ID": "14",
      "op_status": "Nominal"
    },
    {
      "unit": "C",
      "status": "'OK'",
      "sensor_type": "Temperature",
      "temp": "40.00",
      "Type": "Temp 2",
      "ID": "15",
      "op_status": "Nominal"
    }
  ]
}

(This is just an example, there are 20+ sensors).

Using the template in Developer Options I can extract a single temperature that Iw ant but I want to be able to make a group of sensors from all of the available readings.
How can I create this in my configuration file?
Soemthig like this

- group
  temp 1:
     name: '[{value_json.Readings[0].Type }]'
     value_template: '[{value_json.Readings[0].temp }]'

  temp 2:
     name: '[{value_json.Readings[1].Type }]'
     value_template: '[{value_json.Readings[1].temp }]'

Any help in getting this done would be much appreciated
Thanks

I tried to put all of my sensors into a separate servertemps.yaml

-platform: mqtt
  state_topic: 'server/temp'
  name: 'server_temp_0'
  value_template: [{ value_json.Readings[0].temp }]

and this in my configuration.yaml

server_temps: !include servertemps.yaml

The problem is this works when my sensors are inn configuration.yaml but not when i include it in configuration.yaml.

I also have this in groups:

server_temps_group:
  name: Server Temperatures
  entities:
    - sensor.server_temp_0
    - sensor.serber_temp_1
...

But the sensors do not appear in the group
I get the following error when I reset HA

Logger: homeassistant.setup
Source: setup.py:104
...
Setup failed for server_temps: Integration not found.

Any thoughts please

server_temps: !include servertemps.yaml

That is not a valid include, and is not an integration either.

Create a sensor.yaml, and use

sensor: !include sensor.yaml

and put your sensor definitions in there.

So I cannot have any include name I want then? They have to be from some list?
And shouyld it be:

sensor: !include sensors.yaml

???

From my configuration.yaml :

python_script:
group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
binary_sensor: !include binary_sensor.yaml
sensor: !include sensor.yaml
switch: !include switch.yaml
light: !include light.yaml
input_boolean: !include input_boolean.yaml
timer: !include timer.yaml
scene: !include scenes.yaml

You just can’t invent topics to include, so no

server_temps: !include servertemps.yaml

and yes, if you name your sensor.yaml sensors.yaml, you just use :

sensor: !include sensors.yaml

Hmm
Got my server temp sensors working but I assume then that

sensors:

in configuration.yaml no longer work?

Just confirmed that myself, so is there no way to have multiple “sensors.yaml” files?
I only have like 4 sensors and the file is huge!
The final “sensor” has 30 readings from a long JSON

Since it are mqtt sensors, you can take them out of sensors.yaml and use auto-discovery messages instead. You just need to write auto-discovery messages and publish them with the retain flag set.

Another way to reduce the contents of your sensors.yaml is to use packages :

homeassistant:
  packages: !include_dir_named packages

I dont know what that means, how do I implement that?

Thanks - explains it well