Sensor moved to new subnet

Hi,

I am using ESP8266 as sensors in my HA installation.
They are connected to my WLAN. In order to clean up my network, I decided to create a own IOT-Subnet for sensors, switches etc.
Now I changed the WLAN-Secrets in ESP Home, cleaned up the builds, and recompiled/installed the firmware with the new WLAN-Credentials.

So a´far this worked, the sensors where moved to the new WLAN with its own IP-Subnet. I had to remove an reinstall the sensors in the ESP Home integration, all historical data where reattached.

BUT: In the ESP Home Addon the sensors are shown as offline, so I cannot make any changes to the yaml anymore and install it. How can I tell the addon to use the new IP-Adresses for those sensors?

Check the “use ip” (ping) in the esphome settings

  1. Get your routing sorted

  2. Use the ping option in esphome.

The routing is good and I set up the ping option… the only thing I forgot was to use the use_address: x.x.x.x statement in the sensors’ yaml files.