Separate zwave2mqtt for heavy traffic sensors

Tags: #<Tag:0x00007f3f16089088>

Hi
I’ve got some energy meters that are flooding my zwave network, and slowing it down.
I’m looking into using the zwave2mqtt (with a separate z-wave stick that I have laying around) and feeding Home Assistant with the measured values over mqtt, whici has better capacity.
I’ll be installing it on the same NUC as Home Assistant, but in it’s own docker of course.
My plan is to use this new zwave network only for sensors/meters, i.e. mostly one-way communication.
Is this a good idea?
Or will the original zwave network still be flooded?

How often are your meters reporting?

I’m not a zwave expert but wouldn’t the two separate networks continue to operate at the same frequency?

As far as I know, zwave doesn’t offer a choice of channels (like WiFi where each channel corresponds to a slightly different frequency). Therefore even if you created ten separate zwave networks they would all contend for the same slice of the RF pie.

Yes, that’s one of my worries. But maybe the bottleneck is in the controller, and not in the radio frequency.
I don’t know, and I know of only one way to find out…

I’ve set them to defaults, i.e. report at 10% change in power, and every 10 minutes.
But they send a lot of data all of the time, and nobody can help me to get it reduced.
Of a ozw-log of 1,5 million lines, something like 60-65% were from the meters.

Which meters do you have?

Qubino 1 phase and 3 phase meters.

Case A: One controller handling 50 devices.
Case B: Five controllers handling 10 devices each.

It’s easy to assume Case B would work better because each controller has fewer devices to handle.

What’s overlooked is that all 50 devices continue to communicate on the same frequency. In other words, they continue to talk on the same channel and, obviously, they can’t successfully talk at the same time.

Multiple controllers may introduce another issue. Because all controllers are listening on the same frequency, a device’s message is received by all controllers. Only the controller that was paired with the device will accept the message. The others will reject messages that don’t belong to them but, of course, only after having received them.

Anyway, good luck with the experiment.

Set option 40 to 0% (disable)
Set option 42 to 300 or 600 seconds

This will reduce the reports and latency on your zwave network.
This is how I have my Aeotec Meter setup and I don’t get latency issues. :slight_smile:

I tried that (again). It results in no data at all from the meters. BTW: My Aeotec meters work just fine.
There might be a problem with my config, although I’ve tested a lot of different stuff in there.
If someone has an xml config that is proven to work, please post it here!

If those settings are producing no data, that’s sounds like a firmware issue, have you checked with their support team?

About 1-2 years ago when I was still migrating Zigbee devices from SmartThings over to ZHA, I had both hubs sitting right next to each other for a few months, both controlling their own Zigbee network. I basically had a few straggler devices that I couldn’t migrate yet (and keep stable on ZHA), so I left them on ST.

Aside from the ST network having poor mesh quality since I moved almost all devices out, the devices on it always worked. I never saw problems with interference. Probably wasn’t ideal, but it did work.

Zigbee from what I understand uses multiple channels, zwave on the other hand does not and two zwave networks would likely slow each other down in the same house.

Zigbee != zwave

You’re right. I’m used to reading more about Zigbee2MQTT so I must have transposed it in my head. Sorry for any confusion.

To those of you who suffer from slow z-wave networks, or network flooding:
I´ve been having HUGE problems with my z-wave network. Unacceptable latencies and very erratic behavior.
The source of these problems have been my (otherwise excellent) Qubino smart meters (5 of them). They have been flooding my network with meter readings of many kinds. (Yes, I have tested ALL possible combinations of settings several times, and I’ve had long support dialogs with Qubino.)
The problem is now solved!
I excluded the qubino meters from my main z-wave network and added them to a separate network/Aeotec stick, and using Zwave2Mqtt to communincate with Home Assistant.
It has been working very well for many weeks now (and my wife has stopped complaining)!
So my conclusion is that it wasn’t the 868MHz radio band that was flooded. It was the Aeotec stick that couldn’t handle all the traffic. Both sticks are installed on the same Intel NUC.

2 Likes