Setting up Node-red on Home Assistant in a Synology docker container

Ah thanks. @flamingm0e Weird never had any issues w/ the 25 + containers i’m running and having to jack w/ perms on the mount. That seems to have done it.

I have about 14 containers running my home automation stack, and I think node-red was the only one that gave me any permissions issues (aside from mosquitto, but that worked, it just wouldn’t log anything)

Lol haha, I had mosquitto working at one point I believe but possible this was also my issue. I ended up getting mosca to work instead. I’ve seen you alot on here particular docker, you’re a ninja thanks for helping the community. The HA community in general seems so cool, no one is really a dck.

1 Like

Now that I got it working you familiar with possibly getting the result of this call to MQTT or orhterwise? Trying to get top 10 recently added in a card on HA to do sanity check ?

Call a Kodi JSONRPC API method with optional parameters. Results of the Kodi API call will be redirected in a Home Assistant event: kodi_call_method_result.
Parameter Description Example
entity_id
Name(s) of the Kodi entities where to run the API method. media_player.living_room_kodi
method
Name of the Kodi JSONRPC API method to be called. VideoLibrary.GetRecentlyAddedEpisodes

Sorry, I don’t run Kodi and don’t know the API

@flamingm0e I keep ls -la my mount and notice that my docker user isn’t listed on all the folders/file anymore. Super confused, any ideas?

Did you chown the directory?

Yessir I did

been trying for days to get node red working on a synology DS518+ using the /data parameter … keeps on crashing at start up
chmod 777 on the data folder was the solution:)

now i have all my components for HA working on one DS981+
Thanks

Throw a pair of these in that DS-918+ … SSD Intel 760p Series 128GB PCI Express 3.0 x4 M.2 2280
… that price equals to ~65$/piece.
I did it, and now that Synology is whisper quiet. No more Hdd head noises during HA restart.
You really don’t need to, but if you have to (I sleep with that box 2…3 meters from my ears and those WD Reds were killing me … :slight_smile: … until I move onto a bigger apartment), but now, I can take it to bed with me and still nothing moves for hours.

On topic:
I’ve got 17 containers running on that DS-918+ box and stumbled upon this post because I would like to try NodeRed also. So far, it appears that if I change that data directory permissions to 777, everything will be fine.
Will give it a try, thanks guys.

1 Like

So I’ve got NodeRED installed via Docker. I’ve pulled the latest image … not the v8 … is that a problem ?
Why am I asking … because I installed node-red-contrib-home-assistant and all the good stuff appeared …
image

… but, when I try to configure my server, I enter the info correctly, but …
image

… what am I doing wrong here ? … Thanks.

P.S.
Here is the docker container … maybe I missed something ?

Do I need to do some port forwarding in my router ?

OK, I’ve deleted the latest version, and installed the version with -8 at the end … v.0.19.2-v8

Installed the pallete … still the same error … it’s like it cannot connect to my instance.

Here are the logs:

OK. There is a bug. This is a weird bug, but it requires you to deploy LITERALLY ANY OTHER FLOW that doesn’t use home assistant.
Grab an inject node, and attach it to a debug node, and deploy. Then try to connect to home assistant.

1 Like

Worked like a charm !
Now this is some next level right answer from the first try sh*t right there my friend.
The connection with my Home Assistant instance went right through, with one minor change if I might add …
In the server name field, i wrote the name of my actual HA home location name (default Nodered assigned name is “Home Assistant”) … should not matter at all but I mentioned it here for others in the future:


… don’t know if that altered something, but your advice was right on point.

This little test works so well …


Next, i’ll have to try and convert some regular automations.

Thank You so much…:slight_smile:

You can quite literally name it whatever you want. It is just a reference for Node-Red to differentiate between potentially different servers you may have. It does NOT need to be named the same as your Home-Assistant name

Hey - I know this is a fairly old post but I hope you could perhaps guide me. I’ve tried to read through all the good suggestions but seem to fail at the end. I have set up HA and Node-red in docker. But I cannot figure out how to connect the Home assistant server into Node-red… I installed the node-red-contrib-home-assistant-websocket

Are you using the ‘v8’ tagged version of node-red image?

Based on your image, I suggest you get rid of the legacy api password, and move to the long lived token. Also, obfuscating your LAN IP doesn’t do anything for security. It’s only available to YOU.

Not sure what tagged version means - anyway in the docker I have installed nodeversion 8.15.1
I tried with a long-lived token - now I get an API error instead.

I got it to work - did a wrong call for a service node… Thx for your fast and efficient help :slight_smile:

Docker tags are important.

image: nodered/node-red-docker:v8