Share your Floorplan


#472

It’s works on my Android phone and tablet. Thanks


#473

I got this error :

Uncaught TypeError: Class constructor HaPanelFloorplan cannot be invoked without ‘new’

Anybody who knows what to do ?


#474

@Faecon Which browser are you using? HA 0.70?


#475

Running 070.1


#477

My Floorplan


#478

As seen in an example in this topic I want to show temperature. This works, But I want to add a big “C” but this is not shown in my floorplan . What did I do wrong ?


#479

my code:

floorplan.css

https://paste.ofcode.org/aHef42YL3AsdNWwPe2aGTd 

floorplan.yaml:

    - name: Fans
      entities:
        - fan.server_room_fan
      states:
        - state: 'on'
          class: 'fan-on'
        - state: 'off'
          class: 'fan-off'
      state_transitions:
        - name: On to off
          from_state: 'on'
          to_state: 'off'
          duration: 2

in my svg add:

fan.server_room_fan

not work for me


#480

Put the big C in it’s own seperate object.


#481

do you mean in a seperate toplayer ?


#482

You should only give your two zeros the entity id’s name. The rest should not be linked to an entity_id in your svg document.


#483

A separate one from your zeros.


#484

my c has this ID:flowRoot912-8 , and my 2 zeros : sensor.temperature_158d0002376460.
They are in seperature layers. But the C is not seen …


#485

Try moving it to the top layer then.


#486

it is already …


#487

Could be a missing font, or something similar as well.


#488

Ok, then it is something wrong with your grouping. Probably is your background above your C. You need to be sure that your C is above your background in your group, else move your C directly under your layer, so you are sure it is over the background. And be sure that your background is below your C.


#489

changed font, nothing happened, layer with c is on top … nothing happened


#490

Tried this instead?

@-webkit-keyframes rotation {
		from {
				-webkit-transform: rotate(0deg);
		}
		to {
				-webkit-transform: rotate(359deg);
		}
}

Probably won’t work, but worth a shot. I suppose the fan component reports state on or off? (not a number in percent or something)?


#491

What happens if you color your C to red and move it to the white space (where it cannot be be hidden under a layer)?


#492

Ok, guys. Thanks . I did what @Zepixir said. Trial and Error, and now it works !