Shelly 1 Gen1 MQTT external switch missing

Dear community,

I already tried the search here and google, but found no real solution.
First of all, I’m very new to HA, coming from ioBroker

My problem is, that I’ve added the shelly to my garage door. I added an external switch to show if the door is open or not. That worked perfectly in ioBroker, but not in HA.
I tried the shelly integration and simple mqtt. Shelly integration seems to recognize the external switch, but it is not updating in realtime (I think it’s because it pulls the information and not get pushed). MQTT should push it, but seems not. MQTT is showing an entity “binary_sensor.shelly_1_garagentor_input_0”, but it should be sth. like “*external_switch”. So I can’t see any switch status.

I also worked with the documentation which told me to enable “CoIoT” and enter HA as unicast server. This doesn’t worked for me.
The HA automation “Shellies discovery and announcement” is running too, but… Nothing…

Is it possible to add the missing MQTT topic or sth like that?

Thanks in advance!

I‘ll replace my Shelly with an esp8266.