Shelly dimmer 2 random values blinking

Hey, I’m new to Home Assistent. So the answer to my question might be obvious. But I couldn’t find an answer on the forum (or Google) so here I am.

I installed 6 Shelly Dimmers. They work fine in the Shelly app.
Then I successfully added them to HA. Everything works except the dimmers appear to constantly change values in the HA front end. The lights themselves are not blinking, and they work as expected in the Shelly app.

I did a test in my previous home with one Shelly dimmer 2. I didn’t have this issue back then. In the mean time I updated Home Assistant and the Shelly firmware (HA doesn’t support the older firmware of the Shelly’s anymore).

I tried changing several options in the Shelly app (mostly switch types) and I tried resetting the Shelly’s. This didn’t work.
Next I tried reverting HA back to 2024.3.1. This didn’t help either.

This is a video of the issue:

I hope someone can help me in the right direction.

This issue seems to be fixt in the latest update. Thanks!