Shelly RGBW2 with Tasmota - Switch Action should only turn on White Channel

Hi,

I have flashed my Shelly RGBW2 with Tasmota, everything works fine. The integration into Home-Assistant works. I also made the switch working with the adapter and the correct debounce settings. So far all good.
Now I would like to use the switch to only turn on the “white” channel and not the others. The other channels are controlled by automations from HA.
Based on that articel (Shelly RGBW2 - Tasmota) I think this should work but I do not understand how to configure the setoption and rules correctly.

Could someone help me ? The basic idea is to have the already existing light switches to turn on normal white channel light in full brightness. The automations are used then to indicate some other states with the RGB channels.

Thanks

I solved it after some tinkering.

First “SetOption37 128” as found here: Lights - Tasmota
So we have a separate white channel switch.

Second, changing the GPIO settings in “Configure Module” to use Switch_n == 2 instead of the previous value “1” did the trick.

I love tasmota for this flexibility :slight_smile: