Should I use HA's remote or the android companion app?

Hello sorry for a newbie question,
I am new to HA and Nabu Casa which I have paid for.
I just did a new clean install of HA trying to fix a problem.
When I was trying to use the companion app and the Nabu Casa link for my HA at different times, I think I confuse Nabu Casa and HA. I think where the companion app signs be back in automatically as soon I log out, so when I try the Nabu Casa url for my HA, It thinks that I’m already logged in and gives me a error.

So my question is should I be using the url that Nabu Casa gives me or the companion app for my android phone running android 14?
Should I use one or the other or both?
What is this webhooks thing and do I need to do anything with it?
Thanks Confused,

you seem to have hit a weird state. Try this

  1. Make sure the cloud is signed in and remote access is enabled.
  2. Clear data in the android app
  3. Open the app and select your instance and the URL should be stored automatically

WOW thanks for FAST reply.
I have totally removed the companion app from my as I was not sure if I should use it or the url.
As I recall when I installed the app on my phone before and turned on wifi;
it found my HA local which of course I can not use if I’m away from home.
Is that correct or do I need to do something different with the app or my wifi?

Thanks Again,

that is because you probably did not enable remote access before setting up the app. That is ok. Just go to Settings > companion app > Select the first server and set your URL there properly making sure to enter the remote URL and the internal URL.

Ok I reinstalled the companion app on my phone.
It could not find anything till I turned on my wifi and the my local wifi HA server showed up. I tried to set the url’s but it does not allow me to change anything but,
the companion app is still working even after I turned off wifi.
So it would seem that I just use the companion app and not use a browser to to the the Nabu Casa url. If that correct? Using the app and a web browser with the Nabu Casa url seems to be what created my problem.
When I go back into my cloud settings my cell phone now appears under the webhooks area but it is off but, remote is on.
So I take it that the companion app has me logged to HA all of the time.
Thanks, I just hope that I don’t mess it up again.

that is expected discovery requires to look at your network.

you change it after you login and get to your dashboard following the same steps from above. Settings > Companion App > Select your server > change URLs

using the web browser and app at the same time does not cause any issues

you dont really need to look at those, the app handles the creation and usage of it. You just need to leave remote access on all the time otherwise the app will not be able to send data back home.