Silicon labs UZB-7 and z-wave

I have a silicon labs UZB-7(SLUSB7000A) which I have on windows with HA on VM. Installed drivers and associated program Silcon Stuido, Zwave Controller and z-wave sniffer. On HA I have installed z-wave JS and I think I have the correct setup on config. However, when I add the add-on, remove the tick “Use the z-wave js superviso ad-on” and connect with ws://localhost:3000,
I get an error to connect.

What am I doing wrong. Thanks for the tip :slight_smile:

Why are you unticking “Use the Z-Wave JS supervisor add-on” and just trying to connect to it via a local socket, are you running Home Assistant core or supervised and have already installed Z-Wave JS add-on separately in the same Docker? If so then maybe want to run zwavejs2mqtt in a separate VM instead? See different options in advanced instructions →

Or if had simpky instead just use HAOS/HASS (Home Assistant OS) installation on your VM then you should just need to configure USB-passthrough in your virtualization hypervisor and then install Z-Wave. Can not help with Home Assistant core or supervised myself as I run an HAOS/HASS installation with the official Z-Wave JS add-on (“Option 1”) myself.

Regardless, that is all assuming that you have already flashed the latest Z-Wave Serial API Controller firmware image for EFR32ZG14 to your Silicon Labs UZB7 USB adapter which you need to do first before doing anything else, read this discussion about Silicon Labs UZB-7 USB Stick (Silabs SLUSB001A / SLUSB7000A) Z-Wave 700 Controller here →