Skyconnect migration feedback and Innr GU10 Bulbs issues

I thought I’d share my experience of Migrating to the SkyConnect device.

I have 70 different Zigbee devices on the network, from a wide variety of manufacturers.

I received the SkyConnect last week (20/02/2023). Backed up the system and then used the migration facility to move from the “Sonoff Zigbee 3.0 USB Dongle Plus”.

The intention was to move all the “supported devices” to ZHA and the SkyConnect.

Troublesome devices would then be managed through Zigbee2MQTT with the Sonoff Dongle. These devices are mainly mmwave HPS devices that have been a nightmare in ZHA. The Aqara FP1 is OK, but not as great as the “general buzz” would indicate. A Moes HPS device is only practical through the Tuya cloud integration, and the other clone TS0601 HPS devices are ok in ZHA. All have parameters missing in ZHA that are accessible in Z2M.

In the whole, it went well.

  • Hue bulbs – no issues (and I have all sorts of models in use.

  • Sonoff Zigbee switches BASICZBR3 , one needed repairing, one didn’t.

  • Hue Wall Switches – Version 1 and 2 – no issues

  • Hue Tap switch V2 – no issues.

  • Hue External Motion detector – no issue.

  • Hue Internal Motion Sensors – 3 had to be re-paired, 1 was fine.

  • Sonoff TH sensors – half fine, half have stopped working and will not re-pair.

  • Sonoff buttons – no issues

  • Benemart Tuya Zigbee Blind Motors – 5 no issues – 1 needed re-pairing (at the far end of the house).

  • Sonoff Door Sensors – no issues

  • LK Zigbee GU10 bulbs – no issues

  • Aqara leak Sensor – no issues

  • Aqara Motion Sensors – no issues

  • Aqara P1 Motion Sensors – no issues

  • Innr LED Strip – no issues

  • Moes HPS – Finds the device, but no entities reported or exposed anywhere!

  • “Tuya” HPS devices – had the re-pair one, the other was fine

  • Aqara FP1 – no issues

  • Innr GU10 bulbs (RS227T) – lots of issues.

  • The ZHA Configuration gained 3 Silicon Labs Zigbee dongles – deleted the two orphans and all OK

The Innr bulbs have been the only real problem. I have 11 in the kitchen which are setup on the Moes HPS and Aqara P1 (as a binary sensor) to come on with motion and turn off with none These work as a Zigbee Group (as the light.on service lets me set the parameters as required. They also use the adaptive lighting HACS plugin. On the Sonoff Dongle this worked very well. I was keen to get this local as it has a 3-5 second delay using Tuya cloud. Also, the full configuration was not exposed in ZHA (so I configured it in the Tuya Cloud).

The lights started showing am “Identify” double flash at random times.

Some switched on when requested, some didn’t, and never the same ones.

Some were at the correct colour temperature, some were not.

Some switched on 2 seconds after being switched off!

All of this showed no pattern to help, and nothing in the logs provided any help.

So far I have

  • Moved from USB3 to USB2
  • Tried a longer USB cable and sited the dongle out of the cupboard that houses everything else.
  • Removed the Zigbee Group and configured then as a
  • Made the device configuration consistent (as it wasn’t after the migration)
  • Run “reconfiguration” in the ZHA device info. It has to be run twice to be shown as successful
  • Removed the Adaptive Lighting HACS integration (cited as a cause of switching on switched off was run)
  • Tried the Service call to area, device and entities.
  • Tried a simple on/off in the devices area (so just one at a time) and this is OK!
  • Moved the WiFi AP in that room to Chanel 11 (Zigbee is 15) so there should be no overlap.

I have spend hours trawling through the logs and forums -all to no avail, It now just these devices that have issues, so I’m coming to the conclusion it is a SkyConnect/Innr GU10 bulb issue. (strange that the LK GU10s appear identical on the outside, but they have no issues at all)

So far, the only working solution is the use of a physical switch 🤦Even then thay come on with different settings, even though they are all configured the same)

I’m now looking at running Z2M on the Sonoff Dongle to connect the Innr GU10s, the Tuya and Moes HPS devices.

Has anyone else seen this type of issue?

I have also migrated to the Skyconnect, my experience was not as good, though I did take a chance.
I was running a Conbee II and when I started the migration HA told me that the version of firmware I was running would result in devices not connecting until they were power cycled, but upgrading Conbee firmware is not simple, so I risked it.
Power cycling devices did not bring back my Zigbee network, I power cycled HA and the devices a few times with no success.
I have now put each device into pairing mode and re-added them. bar a few outliers I now have my zigbee devices working again.
I paired my Ikea routers to the skyconnect and then most other devices to the routers.
I have working Hue and Innr light bulbs, no issues re-pairing via routers.
Hue dimmer switches working
Cheap 2 relay device working
Hive sensors working.

The only issue I have left is a few Ikea open close remotes that all paired fine, but only one seems to be functioning for some reason.

My installation consists of Hue bulbs, Geldopto strip controllers, Lidl bulbs and a lot of Aqara sensors.
ZHA and Deconz dongle
For a long time this functioned without problems, until I added 13 innr GU10 bulbs.

They are configured in 11 zigbee groups. Only with the 3 innr groups there are problems.
Slow response, no response, lights dropping out so repairing was essential.

  • Update Deconz dongle to the last firmware: no success
  • replaced the Deconz dongle with another Deconz: no success
  • replaced the Deconz dongle with Sonoff ZBDongle E: no success
  • transfered the Innr bulbs to a Hue Hub: Innr bulbs operate stable and fast

For me, it seems to be a problem with the combination Innr and ZHA.
I want to test the following:

  • against my principles: install zigbee2mqtt and control the Innr bulbs with this
  • according to this overview, a firmware update is possible on the Innr bulbs: