Skyconnect - Multiprotocol support is already enabled for another device

Hi all,

I’m trying to configure my SkyConnect, but after pressing ‘Configure’ I get a message stating ’ Multiprotocol support is already enabled for another device’. I’m pretty sure I don’t have any other multiprotocol devices configured. Do you guys have any idea how to fix this?



I’m getting the same error. I know that I caused mine, but I don’t know how to fix it. The way I caused this is that I enabled the multiprotocol support in HA, then restored a previous backup. After I restored the backup, HA was unaware of the multiprotocol support being enabled, so I tried it again. Now I’m getting the " Multiprotocol support is already enabled for another device" message. I don’t know how to disable then re-enable. Can someone please advise?

I had the same issue, but was able to move a step further in the troubleshooting process.

If you search the settings for multiprotocol, you will find that an hassio addon ‘Silicon Labs Multiprotocol’ is installed. As this wasn’t running, and I couldn’t change the settings to get it working, I removed the addon. After that the ‘Configure’ button for SkyConnect (in Settings > Hardware) allowed me to configure it again, installing the addon again etc.

It’s unfortunately not the whole solution, but I hope it will help you all get a step further.

1 Like

My ZHA now unworking. Did the same as @rosshenning as I found nothing but issues with 2023.6.0. Going back to 5.4 has only caused more issues. Now I figure I have to move forward and try and fix the new issues somehow.

I tried something different to @Slaut, I tried to re-add the usb device-by-id that I had previously configured for my Skyconnect device in the Silicon labs multiprotocol addon config, by adding it through yaml config. The only usb options available in the dropdown are /dev device names and I had issues with this in the past. The new usb-by-deviceid setting sticks but doesn’t show in the UI.

Logs look mainly OK but get a lot of “can’t connect, seems unresponsive” and of course I can’t load ZHA as there is nothing for ZHA to connect to.

I’m stumped.
** edit:
I’m now unable to access the ZHA integration, it won’t load and so doesn’t show for me to be able to change config. Way to go config-flow!

I see these in logs:
13:11:53 – (ERROR)

Error occurred loading flow for integration zha: Exception importing homeassistant.components.zha.config_flow

Unexpected exception importing component homeassistant.components.zha
13:11:53 – (ERROR) components/zha/core/ - message first occurred at 13:10:58 and shows up 3 times