Slow restart


#1

I have headless raspy3 with hassbian. On one board everything runs OK and after reboot it takes about 30 - 60 seconds to load HA. On other board it takes almost 5 minutes. There must be some problem waiting to continue to boot. But how can I check it if I have headless system? thanks.


#2

If you have SSH enabled, then you can connect to the pi and watch homeassistant start up.
I have not run hassbian, but since it is based on a std pi load, this should work.

stop HA then run try the following commands
sudo systemctl start home-assistant
sudo journalctl -fu home-assistant.service

The second command captures all of the activity from HA. When you are done, you can press ctrl-C.


#3

I’ve found the bluetooth device tracker slows down startup greatly, if you have that enabled try disabling it.


#4

You could enable more logging info using …

on the pi that’s playing up. I would set the default to info restart HA and look at the log after a couple of mins.


#5

Try checking the size of your database. There was a discussion about it here


#6

Well I tried to make sudo reboot via SSH while pinging the raspberry. Immediately after sudo reboot ssh disconnects but ping is running without interuption. After a few minutes raspberry makes restart and after everything goes as in standard way.

So the problem is it takes long time to reboot - not to go live after reboot and while ssh is being cut just after the command is sent I have no way how to check what is going on. Seems like I have to connect some screen.


#7

@Jiran

I’m have the same issue. Did you figure out what was causing it?


#8

Nope boy… but now with latest version it is better…