SMA Solar integration - Consumption not right?

Hi there,

first of all, many thanks for maintaining a chance to monitor our SMA Solar Things :slight_smile:

Now for my question:
I did setup the SMA integration and it works well, BUT since i’m especially interested in the current consumtion of my household, i noticed an odd behaviour.
If i compare the readout from the current_consumption-sensor from the SMA Solar integration to the value given by the “Sunny Portal” Web or the SMA-App on my phone, i get a not too slight difference.

Is there anything i’m doing wrong here, or are these two different things?

Please see the attached picture (small gauges are in HA via SMA Solar integration - lower ones are the scales given by the SMA Sunny Portal and the App…


Could someone elaborate on this matter or is experiencing the same?

Thanks :slight_smile:

Update: Right now i noticed an even worse 300 watts (sensor) to 2.4 kW (sunny web) on the house, while solar generating is about 2.5 kW…

Hi, I’m always trying, but somehow I don’t succeed. I already have all the options with the host name. Can you help me a little? I don’t know what to do next.
Thank you for your help.
Boy Stefan

Having the same questions, @Bimbo007 and @cpo can you share perhaps your config or update how you done it?

Can you please share what hostname you have put to connect and integrate your SMA in HA ?
I normally access its web interface via … but I always get connection or authentication rror when I try to setup the inverter :frowning: and this using the user or installer profiles


i did setup my solar and battery inverters with the IP adress as the hostname, no ssl, no ssl check and a user profile / password.

That’s really all. Works flawless. Can i get you some more information?

Well, I normally access my SMW SB 5.0 via in any web browser at home … but when I try to add the SMA in HA, It just says connection error as you can see here :

Sorry, you seem to make everything right.
Last idea: As in my setup the webinterface is connected via https, have you tried to tick “utilise ssl” but NOT “verifier …”?

yes, and no luck … but it looks like a lot of users have this issue

@cedricdelecole I have the exact same issue. Did you find a solution for it yet?