Smartwingshome blind unavailable

I have Smartwingshome blind with ZigBee motor. It was working fine for several weeks. It became “unavailable” yesterday. Battery is 100%, charged yesterday. I can still control it using the remote.

Home Assistant using ZigBee2MQTT, Sonoff dongle P coordinator.

I restarted Home Assistant already.

Anyone knows how to fix this? To make the blind available again.

Did you try to pair it again?

No. I guess I need to try that.

I’m guessing you have the “Availability” option in Zigbee2Mqtt enabled, in which case, for some reason the Smartwings blinds are hard coded as Mains devices instead of Battery. I believe this means Z2M will ping it every 10 minutes (or whatever you set the option to) instead of the battery setting which is something like 1440 minutes.

This drove me insane having them keep showing offline in Home Assistant. It is very possible for the blind to miss the ping or not respond due to it sleeping and conserving battery.

So, your options are to either disable the availability optional completely, change the timeout for the smartwings devices for each device (see below) or change the global timeout to be something larger like 60 minutes and see if that works.

  "0x0cae5ffffe89ab64":
    friendly_name: My SmartWings Blinds
    availability:
      timeout: 1440

In general, 10 minutes can be a suboptimal default when you have lots of Zigbee devices, they should have some kind of formula because I have over 100 devices and the traffic to ping all of them every 10 minutes would be insane…