SMTP Notification.. Stopped!

Ok… I had this working yesterday… and today it stopped working.

The Notification IS NOT showing up in my entities listing
From My Log I’m getting
“Setup failed for smtp: No setup function defined.”

  1. What are the requirements for SMTP xFer of messages I’m thinking I don’t have all required… even thought it was working yesterday… My installation IS NOT open to the internet… but as I said… it was working yesterday

From My Log I get this after a restart
“Setup failed for smtp: No setup function defined.”
and

2019-07-16 19:33:03 ERROR (MainThread) [homeassistant.setup] Setup failed for smtp: No setup function defined.
2019-07-16 19:33:12 ERROR (MainThread) [homeassistant.components.notify] Error setting up platform smtp
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/notify/__init__.py", line 71, in async_setup_platform
    platform.get_service, hass, p_config, discovery_info)
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/smtp/notify.py", line 71, in get_service
    if mail_service.connection_is_valid():
  File "/usr/src/homeassistant/homeassistant/components/smtp/notify.py", line 116, in connection_is_valid
    server = self.connect()
  File "/usr/src/homeassistant/homeassistant/components/smtp/notify.py", line 109, in connect
    mail.login(self.username, self.password)
  File "/usr/local/lib/python3.7/smtplib.py", line 697, in login
    "SMTP AUTH extension not supported by server.")
smtplib.SMTPNotSupportedError: SMTP AUTH extension not supported by server.

My Config does have the:
smtp: componet defined

My Notify group

notify:
  - name: email_notification
    platform: smtp
    server: smtp.gmail.com
    port: 587
    timeout: 15
    sender: [email protected] <== Email matching th elog in below
    encryption: none
    username: Gmail_Acct_LogIn
    password: XXX
    recipient: 
      - [email protected] <== second gmail account
    sender_name:  HA

Have you allowed less secure apps for the gmail account?

https://support.google.com/accounts/answer/6010255?hl=en

Sorry… Yes…

The biggest problem I think is that the notification “notify.email_notification” isn’t visiable in my entities list

It’s not visible because:

 Setup failed for smtp: No setup function defined.
...
SMTP AUTH extension not supported by server.

Try:

encryption: starttls

Setup failed for smtp: No setup function defined.

SMTP AUTH extension not supported by server.

Yep I saw that… I added it back in… again… no joy!

There is a bug that requires internet access for smtp to enable when hass starts. Maybe that is related?

That might explain why Its not working NOW ( I dont remember if I restarted HA yesterday… But I have restarted since), but not how it was working yesterday…

Now the second problem is why the notification entity isnt showing up i the build!

thanks all BTW for the help!

As I said before it’s because the platform cant be set up on restart of HA.

If the platform setup fails then you aren’t going to get any entity generated.

DOH! You’re right

So at some point SMTP got broken after a restart… bummer.

I’m trying to get the “lay of the land” before I start using Nabu Casa and paying its charges. Guess I’ll move onto other features and circle back to notifications when HA is opened up

Thanks all!