Home Assistant Community

[SOLVED] Alarm_control_panel.alarm_trigger service doesn't trigger the alarm

#1

Hi everyone, first time poster here !
I recently fell in love with HA, and i’m starting to have a nice set up (for a newbie). I’m now setting up an alarm with the alarm control panel, everything seems fine, except that I can’t make the alarm_control_panel.alarm_trigger service work, even manually. I first thought I had a problem in my automation (although I got it from the documentation), but I realized that when I call the service from the development tool, it never triggers :

image
When I click “Call service”, nothing happens.

It works with very other service : arm_home, arm_away, disarm…
For the sake of my tests, pending time, delay time etc are all at 0.
Does anyone have an idea about that ?
Thanks !

0 Likes

#2

(sorry, can’t post more than one picture).
When I say “nothing happens”, that’s not 100% true, i get the notification :

image

but nothing else happens.

0 Likes

#3

Another weird thing, in the development tool to call a service, if I choose “arm_home” for instance, it automatically select the right entity :

image

But if I choose “trigger”, I then have to manually select the entity…

0 Likes

#4

Sorry, me again (kind of talking to myself), the only way to actually trigger the alarm is to use this tool :

image

The Set State button actually change the alarm’s state to “Triggered”, and then my automation scenario works, got my pushbullet notification.

I hope I’ll find a solution, 'cause if not I’ll have to let a note when I’m leaving : “Dear burglar, here is the url of Home Assistant, please log in with this password and set the Alarm state to ‘Triggered’”. Thanks."

0 Likes

#5

Hmm, looks like I’m the only one with this problem. I’ll keep digging and will try to update my message if I find something, it might help someone in the future.

0 Likes

#6

Ok, found my problem, gonna leave the solution here in case one day someone encounters the same issue.
The key was in my sentence : “For the sake of my tests, pending time, delay time etc are all at 0.”. Trigger_time was also at zero, 'cause i thought it was the time before the alarm triggers… and finally understood it’s the trigger duration. Setting it à 120s did the trick…

Problem solved :slight_smile:

2 Likes

#7

Hey … just wanted to let you know that I had the same issue, and this solved it!

1 Like

#8

It also solve my issue! Thanks!

1 Like