[SOLVED] Alarm_control_panel.alarm_trigger service doesn't trigger the alarm

Hi everyone, first time poster here !
I recently fell in love with HA, and i’m starting to have a nice set up (for a newbie). I’m now setting up an alarm with the alarm control panel, everything seems fine, except that I can’t make the alarm_control_panel.alarm_trigger service work, even manually. I first thought I had a problem in my automation (although I got it from the documentation), but I realized that when I call the service from the development tool, it never triggers :

image
When I click “Call service”, nothing happens.

It works with very other service : arm_home, arm_away, disarm…
For the sake of my tests, pending time, delay time etc are all at 0.
Does anyone have an idea about that ?
Thanks !

(sorry, can’t post more than one picture).
When I say “nothing happens”, that’s not 100% true, i get the notification :

image

but nothing else happens.

Another weird thing, in the development tool to call a service, if I choose “arm_home” for instance, it automatically select the right entity :

image

But if I choose “trigger”, I then have to manually select the entity…

Sorry, me again (kind of talking to myself), the only way to actually trigger the alarm is to use this tool :

image

The Set State button actually change the alarm’s state to “Triggered”, and then my automation scenario works, got my pushbullet notification.

I hope I’ll find a solution, 'cause if not I’ll have to let a note when I’m leaving : “Dear burglar, here is the url of Home Assistant, please log in with this password and set the Alarm state to ‘Triggered’”. Thanks."

1 Like

Hmm, looks like I’m the only one with this problem. I’ll keep digging and will try to update my message if I find something, it might help someone in the future.

Ok, found my problem, gonna leave the solution here in case one day someone encounters the same issue.
The key was in my sentence : “For the sake of my tests, pending time, delay time etc are all at 0.”. Trigger_time was also at zero, 'cause i thought it was the time before the alarm triggers… and finally understood it’s the trigger duration. Setting it à 120s did the trick…

Problem solved :slight_smile:

5 Likes

Hey … just wanted to let you know that I had the same issue, and this solved it!

2 Likes

It also solve my issue! Thanks!

1 Like

thanks for your help I solved mine too :slight_smile:
by the way is it possible to somehow continue the alarm as long as there is motion ?

not that someone think : ok it will piss me off for 2 minutes then i’m good …

I know this is ooold, but thanks for posting this update. I had the exact issue, and couldn’t figure out why my alarm was working, and then suddenly not.

Thanks again!

1 Like

Hey thanks for posting.
I am dealing with this issue now. Trying to manually trigger the alarm when a Zigbee sensor is triggered.
Where did you define the trigger time? not seeing it in the doc (https://www.home-assistant.io/integrations/envisalink)

Have the same problem, but don’t understand how you were able to solve the problem! For those of us who are slow, can you explain where the variables “pending time” , “delay time” are found? I have a several zigbee sensors that I would like to integrate into the alarm system. Are you doing this through automations? Thanks for your help!

Hey mamssw,
I believe I found what totoroyamada was referring to:


Still trying to make it work.
1 Like

I’m having a similar problem. I have a dome siren and an ecolink door sensor, both Zwave devices.
The weird thing for me is that if I just create the automation, it works fine. I tested it for half a day. The next day, I opened the door and nothing. so I check and sure enough, it is detecting that the door is opened. So I thought that maybe the siren isn’t connected but when I activate the siren from the frontpanel it works as well. The ecolink door sensor says “Sleeping” in the Zwave card though… not sure if that has anything to do with it because it still detects it on the frontpanel. Something is not right with the automation then I think.

My configure.yaml has the manual alarm as such:

# setup the use of the "manual" home alarm panel. This should add a card to the front panel after reboot.
alarm_control_panel:
  - platform: manual
    armed_home:
      pending_time: 0
      delay_time: 0

And I built my automation using the GUI, but here’s the results it gives me, again nothing out of the ordinary…:

- id: '1574468021858'
  alias: Front door open triggers alarm
  description: Turn on siren if front door opens
  trigger:
  - entity_id: binary_sensor.ecolink_door_window_sensor_sensor
    from: 'off'
    platform: state
    to: 'on'
  condition:
  - condition: state
    entity_id: alarm_control_panel.ha_alarm
    state: armed_away
  - condition: state
    entity_id: alarm_control_panel.ha_alarm
    state: armed_home
  action:
  - device_id: <Hiding from you...>
    domain: switch
    entity_id: switch.elexa_consumer_products_inc_dome_siren_switch
    type: turn_on
- id: '1574471404053'
  alias: Turn siren off when front door shut
  description: ''
  trigger:
  - entity_id: binary_sensor.ecolink_door_window_sensor_sensor
    from: 'on'
    platform: state
    to: 'off'
  condition: []
  action:
  - device_id: <Hiding from you...>
    domain: switch
    entity_id: switch.elexa_consumer_products_inc_dome_siren_switch
    type: turn_off

I’m banging my head against a wall with this thing.The automation is turned on, the sensor is detecting, the siren can be triggered from the front panel, it literally worked repeatedly as expected yesterday for hours… what the heck else could be the problem? What am I missing?

ok, some help from Reddit led me to a partial solution. By default conditions are AND so I had armed_home AND armed_away as conditions which of course would never work. However, even when I set them up as OR conditions, they didn’t work either. I have to write one script for armed_away and another for armed_home which is annoying… Literally just delete one of the conditions from what I previously posted and it worked for the remaining condition.

Looking at the reddit post, I don’t think your condition block was correct.
A simple set of ‘or’ conditions looks like this, and does work as expected:

  condition:
    condition: or
    conditions:
      - condition: state
        entity_id: alarm_control_panel.ha_alarm
        state: 'armed_away'
      - condition: state
        entity_id: alarm_control_panel.ha_alarm
        state: 'armed_home'

I always explicitly define and / or in multiple condition blocks rather than relying on default behaviour (that could possibly change in the future), so and is:

  condition:
    condition: and
    conditions:
      - condition: state
        entity_id: alarm_control_panel.ha_alarm
        state: 'armed_away'
      - condition: state
        entity_id: alarm_control_panel.ha_alarm
        state: 'armed_home'

Thank you, I see my mistake now. I used the GUI tool to build the automation and misunderstood how it worked. I had added one condition, then I selected then added a second and made it an OR thinkint that would OR it with the first one. Instead. of doing A + B it was doing A(B+…) The … is because I didn’t set up another condition in the OR. Maybe to keep idiots like me from being confused, AND and OR functions can automatically populate with 2 things in the automations configuration GUI.

I wonder if this could help my problem in some way. I have a AD2PI connected to my ademco alarm system. I recently added some 433MHZ smoke and motion sensors and they are integrated thru Tasmota and MQTT and they work. I then created an “433mhz enable Button” from the helper boolean switch and wrote and automation to each sensor as a condition that the enable button has to be “on” before the rest of the automation works. This all works as it should. The issue is that I tried to also have a automation that enables or disables the button entity based on whether the AD2PI is armed_home or armed_away. This automation is not working. Here is the automation that is not working. I first tried to use the state of the entity_id: alarm_control_panel.alarm_panel and not the READY attribute, but that did not work either.

- id: '1611450843281'
  alias: Enable 433mhz alarms from AD2pi
  description: ''
  trigger:
  - platform: state
    to: 'false'
    from: 'true'
    entity_id: alarm_control_panel.alarm_panel
    attribute: ready
  condition: []
  action:
  - condition: state
    state: 'on'
    entity_id: input_boolean.alarm_enable
  mode: single