[Solved] All TTS services has stopped working (tried them all)

Hello.
I am on 2024.6.4.
A few days ago while on 2024.6.3, all my TTS services stopped working. All my automations are running and I don’t have any error messages I can se in the logs.

Here’s my code:

service: tts.speak
target:
  entity_id: tts.home_assistant_cloud
data:
  cache: false
  media_player_entity_id: media_player.googlehome_isabelles_rum
  message: Vi testar lite
  language: sv-SE

It runs perfect, the Google nest speaker (the entity_id) is turned on but nothing is spoken out.

I’ve tried the same code under Dev.tools - Services. No errors but nothing is spoken out. I am subscribing to NabuCasa and under settings, I can get the TTS to work in the browser, but not in any casting-enabled device.

Under Media, I have tried TTS with Google translate as well as Cloud and Home Assistant, but no luck there either.

I can cast and listen to my cast enabled devices as well as talking to those smart speakers.

Seven years with Home Assistant and running, but I have absolutely no idea of how I can make this work again. Any suggestions or thoughts are therefore highly appreciated.


Update: Ok. solved the problem.

In “configuration.yaml” i had to change “internal url” from “http://homeassistant.local:8123” to “http://192.168.0.222:8123”. Restarded HA and now everything is working fine.

Have you tested switching the language to sv?

Google requires https:// access of some type from your external URL. You should have nabucasa cloud enabled there or an accessible https:// address in there.

Open your Home Assistant instance and manage your systems network configuration.

Yes, i uses language: sv-SE in my script

Try just sv, Google had your version listed as Premium.

You might be into something here worth checking out. I use https:// in my remote access URL, but I guess that is not what you are referring to.

Unfortunately the link you provided in your post did not lead to the correct place. If possible, please tell me where in my settings I can find that page.

To bad: “Failed to call service tts.speak. Language ‘sv’ not supported!”.

I received the same message with sv-SE
But sv worked for me.

Did you tried restarting the speaker? It didn’t work with my speaker until I restarted it, I don’t have NabuCasa, so can’t test your setting. But the basic work fine, when I restart the Nest speaker. I need to do that once in awhile, I can tell because my Echo speaker still work while my Nest doesn’t.

service: tts.google_say
data:
  cache: false
  language: sv
  message: Vi testar lite
  entity_id: media_player.basement_speaker_2

You have to have the default_config loaded in the configuration.yaml (which it is by default) or if you messed with that the my: integration, and when that link opens you need to put your HA URL in there. but the link is right and takes you right there.
Settings-System-Network-Home Assistant URL

Thanks for your code. It turns on my speaker, silence and then the speaker is idle.

There’s something else that’s causing my problems.

Yepp, restarted by removing the power cable.
Still no luck.
The code turns on my speaker but then nothing.

I do appreciate your advice.

Ok. solved the problem.

In “configuration.yaml” i had to change “internal url” from “http://homeassistant.local:8123” to “http://192.168.0.222:8123”. Restarded HA and now everything is working fine.

1 Like