[Solved] Automating effect (turn on a Zigbee light bulb with an effect)

Hello everyone. First time poster (mainly on IRC), OH ‘refugee’… So far I’ve found HA to be very easy to set up and configure. However, there is one small item that’s been bugging me since I set up my Zigbee lights… I can get the light to turn on on schedule, but it reverts to the normal amber colour instead or the ‘colorloop’ effect that gives it constantly changing LED colours. Nice for mood-lighting while still giving enough illumination to make it to the kitchen or bathroom, safely. Thanks in advance for any tips!

Welcome and congrats.

When asking for help there’s a few things people will need.

Devices involved (down to the model number - different devices support different things)

Because you are asking about zigbee we need to know what Zigbee integration… ZHA, Zigbee2MQTT, Deconz?

If you ask about what devices should I get we also need to know your Geography because device availability l, power requirements and radio frequencies vary by region.

So what does your configuration look like and what have you tried already?

1 Like

Thank you Nathan. Running a Sonoff stick, using ZHA. As noted, it will turn on, on schedule, without any issues.
Here’s the YAML of the automation:

alias: LR Light On
description: “”
trigger:

  • platform: sun
    event: sunset
    offset: 0
    condition:
    action:
  • type: turn_on
    device_id: f8dbd64737766bee4d9a83f55093564a
    entity_id: switch.sp4
    domain: switch
  • type: turn_on
    device_id: bee1ece51cd47bbef939fa969d92e781
    entity_id: light.zigbee_bulb_1_forceonlight
    domain: light
    mode: single

I didn’t see any web interface option to automate initiating the effect, so I tried adding the line:

But when I try to save it, I get the following message:

IRC FTW… Thanks @JollyRgrs !!! Needed to deal with the zigbee bulb as a service:

  • service: light.turn_on
    data:
    effect: colorloop
    brightness_pct: 100
    target:
    device_id: bee1ece51cd47bbef939fa969d92e781