(Solved) Cannot remove hassio_supervisor docker

Hi all
I have made a temporary installation of home assistant using Docker on my NAS for testing before choosing between HA and Jeedom.
Then finally decided to use HA over Jeedom now so I’ve made a clean installation on my specific mini PC everything went fine but now I want to remove everything about HA from my NAS but when I try to stop or remove docker hassio_supervisor from Portainer, it always restarts and if I removed some other docker about HA but it recreates them also.
Does anyone knows how I can solve this to remove it completely ?

Don‘t know about your NAS GUI, but usually you can force removal even of a running container by

docker rm -f <container>

I’ve run into this and it’s not easy to remove it.

You will need to find the home assistant supervisor system service that is running and stop/remove it. Then you will be able to remove all if the other HA related containers after that.

I’m not by my system right now so I don’t remember what the service is called but if you know much about Linux or if you can look at the installation script that you used to install HA you should be able to find that service listed and disable it.

I’m not in front of it now so I don’t have SSH access to it but I’ve found those command in the installation script:
“systemctl enable hassio-supervisor.service”
“systemctl start hassio-supervisor.service”
I think it is what you were talking about so I will try to stop and disable it.
I will let you know, thanks.

yeah, I’m pretty sure that’s the one.

That are control commands for systemd, process #1 on a modern linux system. Counterparts are (as you might have already guessed)

systemctl disable hassio-supervisor.service
systemctl stop hassio-supervisor.service

But - this will only prevent hassio-supervisor from being startet at system boot and it will stop a running instance. It does not uninstall it, nor does it remove the Docker container images (which use alot of disk space).

Yes, but those are the first steps to take in order to be able to stop the containers and delete them without the supervisor service recreating those containers and starting everything back up again.

Or am I somehow missing your point?

Yes that’s it, it made it :slight_smile:
Like finity said it was first step to avoid a docker creation loop. now that I disabled and stopped that service, I then removed dockers and it doesn’t seems to come back so I think I can confirm that it is solved :wink: